Problem installing Keras on Ubuntu 18.04

I am trying to install Keras via install_keras() on a machine running Ubuntu 18.04. I have installed Miniconda on the machine. Reticulate can find the installation of Minconda:

[1] "conda 4.8.3"
[1] "/opt/anaconda/bin/conda"

But when I go to install Keras:

keras::install_keras(method='conda', conda='auto')
Error: could not find a Python environment for /usr/bin/python3

Even if I specify the path from reticulate::conda_binary, I get the same error:

keras::install_keras(method='conda', conda='/opt/anaconda/bin/conda')
Error: could not find a Python environment for /usr/bin/python3

It doesn't seem to be a problem with finding Miniconda if Reticulate can detect it (and commands like reticulate::conda_create("r-reticulate") work fine).

1 Like

I have the same problem. No solution found yet.

FYI, ultimately, I ended up having to reinstall on Ubuntu 20.04, and this worked.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.