Problem installing dplyr package


I have problem installing dplyr package. It gets stuck every time I try to do it!

Last message:
trying URL ''
Content type 'application/zip' length 3064622 bytes (2.9 MB)
downloaded 2.9 MB

Waiting for 1 hour and nothing happens! Tried many times to kill R and open it again. Restarted computer as well. Nothing helps...

Hi @Jadwiga! Welcome!

I think helpers are going to need some more information in order to help you figure this out. To start:

  • Do you have the same problem when you try to install from R, outside of RStudio? (If you’re not sure of the difference, see: Differentiating R from RStudio)
  • Do any other messages print to the console after the ones you posted? If so, can you please paste them here?
  • When you say nothing happens, do you mean that the last line of the console does not have a prompt (>)? What are you expecting to see happen?

Just in case: sometimes people get confused because package installation is so quick if you’re on a system where R was able to install an available binary (pre-compiled) version of the package. If a new line with a prompt appears, then package installation has finished. To use the package, you need to load it using library("dplyr").

1 Like

Also can you install other packages, e.g. the drat package?

## Drat is small
1 Like

This package got installed quite quickly (drat)

Hello jcblum!

The problem is same in R and in RStudio
There are no other messages.
At the end of installation usually there is a message that a package is successfully installed and a prompt > appears. However, in my case none of this happens (after over 1 hour of waiting). If I try to type sth the program gets stuck and I have to kill the process.

Hmm, very puzzling. This a long shot, but what happens if you try installing dplyr from a different CRAN mirror?

Trying to rule out the possibility that R is hanging up while trying to download other dependencies, or that there’s something wrong with the downloaded file.

Is the output from install.packages("dplyr", verbose=T) more informative on where the process hangs?

1 Like

Thanks @grosscol! This seems to have worked! The package was saved in another folder (on C disk instead) and everything works!

A post was split to a new topic: installing dplyr package -- Error: package ‘bindrcpp’ 0.2 was found, but >= is required by ‘dplyr’