Problem in Installing Tidyverse and dplyr

I have a problem with installing tidyverse and dplyr library. I used

Trace(utils:::unpackPkgZip, edit=TRUE)
and changed the sys.sleep to 2 but still the problem stands.

because of antivirus I use :
install.packages("tidyverse", type = "binary"),

and it seems fine but when I run library(tidyverse) it gives me the error:

Error:package or namespace load failed for ‘tidyverse’ in load namespace(j <- i[[1L]],c(lib.loc, .libpaths()),, versionCheck = vI[[j]])

namespace "R6" 2.2.0 is already loaded , but >=2.2.2 is required.

I tried to install R6 version 2.2.2 but it is not installing.
Any suggestions?

Can you post the complete error message you get when you try to install it?

During the instalation, it seems fine and does not give me any error. when I want to call it, sohws me the error

If R is still asking you to update R6 then the installation process has not been successful as you think, please post the complete console output you get when you run


So we can take a look and have information to help you.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.