Problem in Bioconductor package installation

I have problem in installing some Bioconductor packages like ParathyroidSE and SpikeInSubset. When i print the code to install the package ,


everything looks normal, however when i tried to open the library or see the data, the following message popped out:

Error in library("parathyroidSE") : 
  there is no package called ‘parathyroidSE’

When i tried to open the package using R studio from another computer, the package was installed properly and we could see the data. Does anyone have any suggestion how to overcome this problem?

If I try the biocLite("parathyroidSE") command (after loading the BiocInstaller package), it succeeds on my system, confirming that the package exists. One reason why it might fail for you is that is that your R is too old. Bioconductor packages are tight to specific R versions, so that if you have an old R version, you won't have access to new packages or the latest updates of existing packages. The package has been available for quite some time (first commit to the Bioconductor servers indicates 2013!) though.

We would be able to say if that's the issue with the output of sessionInfo(), which is good to provide anyway when posting queries, and certainly queries about Bioconductor packages. This question is probably better suited for the Bioconductor forum.

Hope this helps.

1 Like