Problem downloading R studio on Mac M1

## R Session Startup Failure Report

### RStudio Version

RStudio 2024.04.2+764 "Chocolate Cosmos " (e4392fc9, 2024-06-05) for macOS

Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) RStudio/2024.04.2+764 Chrome/120.0.6099.291 Electron/28.3.1 Safari/537.36

### Error message

[No error available]

### Process Output

The R session exited with code 1. 

Error output:

[No errors emitted]

Standard output:

[No output emitted]

### Logs

*MISSING VALUE*


MISSING VALUE

Im trying to download rstudio but this error message pops up when i run it. I've also downloaded r and when i run a very basic r program on the terminal it works. The problem lies when i try to use Rstudio. I downloaded R studio a couple months back and no problem with it, now I don't understand why this is happening. Appreciate any help

Hi @Stonox ,

Did you follow steps roughly like the ones described here?

Maybe try resetting RStudio's state.

Are you on macOS 10.15.7 (based on the log you included)?

The current version of RStudio is only supported on macOS 12 or newer. I don't know for sure if this is the problem you are encountering, but you could try installing an older version: RStudio Desktop Releases on Unsupported Versions of MacOS

Actually it looks like that "10_15_7" is NOT representative of the macOS version. Even on my machine running Sonoma 14.5 it says "10_15_7", so ignore my last coment!

I've downloaded the last 2 versions from the link you submitted and the error keeps persisting. Do you think if I factory reset my Mac it will solve it?

Yes @dromano I followed that exactly steps yet the error keeps appearing