Problem connecting to snowflake driver when publishing shiny app to rstudio connect

Hi Friends,

I am trying to publish a shiny app to our rstudio connect server and the app connects to snowflake. The problem we are running into is that the app cannot recognize the snowflake driver that is on the server when I go to publish. The connection works when I just run the app on our workbench server, but the problem comes when I go to publish.

conn <- DBI::dbConnect(odbc::odbc(),
Driver = "/opt/rstudio-drivers/snowflake/bin/lib/",
Server = "server",
UID = rstudioapi::askForPassword("Database user"),
PWD = rstudioapi::askForPassword("Database password"),
Role = "Insert role here",
Database = "Insert database here",
Warehouse = "Insert warehouse here",
Schema = "Insert schema here"

When I go to publish I get the following error.

  1. Preparing to deploy application...Error in response[[listName]] : subscript out of bounds

The deploy tab says that "all paths should be to files within the project directory"

I went ahead and put the driver in my project and tried to connect to it that way as well, but still no luck.

Any insights would be greatly appreciated!

Thank you!