Posit Cloud Jupyter Python Installs

I am trying to install additional python modules into a jupyter hub project based on posit cloud. I am getting errors regardless of installing via pip or anaconda into the base environment from the terminal window.

I dont want to use R or reticulate. Any suggestions?

loud/project$ conda install geowombat -c conda-forge -y
Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): \ Killed

Hi @mmann1123,

On Posit Cloud there are already other versions of Python installed. To use one of the provided versions you can select the version from the "New" dropdown inside of the Jupyter project.

Yes I am aware. However installing additional modules (libraries) seems to be failing. Are you timing out command line operations after a short period of time?

Sorry, I definitely misread your original question. I am able to successfully install it with pip inside of the notebook:

However, if I do it from the terminal it does error out. When I try it with conda, I get the same thing as you where it gets killed. I wondered if it was timing out so I tried to install, so I tried installing conda-libmamba-solver to make it go faster. However, installing conda-libmamba-solver is not allowed since the required permissions aren't given.

Jupyter is currently a beta feature in Posit Cloud so it has some hiccups like this. My suggestion would be to install geowombat via pip inside of the notebook and not from the terminal.