plotweb in bipartite not found


I am trying to run the following

plotweb(NA, low.spacing = 0.139, high.spacing = 0.015, col.high = "sky blue", col.low = "light green", text.rot = 90,low.y = -0.4, high.y = 1.3,y.lim = c(-1.04,2.6), x.lim = c(0,1.4), labsize = 1.2)

but i get the return
Error: could not find function "plotweb"

I have installed bipartite and I can see the function in the documentation. I have also tried naming the dataset. But get the same error.

Am very new to this, sorry if its a silly question - any help would be great! Thanks

Did you run the command


before trying the plotweb command? That should make plotweb available.

I just tried that and got

"Loading required package: sna
Error: package ‘statnet.common’ required by ‘sna’ could not be found
In addition: Warning messages:
1: package ‘bipartite’ was built under R version 3.2.5
2: package ‘sna’ was built under R version 3.2.5"

i think I must have missed something. I see SNA and its ticked.
I am working on a 32 bit mac and cant use the newest packages

thanks so much for quick reply

That was very helpful thanks, I just did what you said and see I need 'statnet.common' which i tried to install but which (it tells me)

Warning in install.packages :
package ‘statnet.common’ is not available (for R version 3.2.2)

:frowning: not sure quite how to plot my network now!
Hmmmm .....

The latest version is 3.6.0. If possible, try to update your R version and try again.

The package statnet.common depends on R version >=3.5, and if your version is older than that, it won't work. What is your R version?

Just checked and its Version 1.1.463! I tried to get the latest version but my operating system is to old to download it (our IT dept. wont upgrade it and they have admin rights!). I will try and download a something in between 3.5 and 3.6 and see what happens. Thanks very much for this!

You are confusing RStudio version with R version, they are two different pieces of software.
You can download the latest version of R from here

Also, have in mind that you have to install just the 32-bit version.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.