Plots not viewable

I'm making a histogram using ggplot but I cannot see the plot produced. There are no errors when I run the code. I can't see it in the Quartz 2 pop up window or the "Plots" pane in the bottom right corner. Anyone know what the issue might be?

Can you view any plot made in ggplot? For example, will it show something if you run:
ggplot(mtcars, aes(x = gear, y = mpg)) + geom_point()

Have you tried running ggsave() after creating the plot? If it saves the plot to file then you know it's something about the IDE/previewer/whatever. If it doesn't save the plot then it probably isn't actually making the plot.

I wonder if the graphics aren't supported by the versions of R and R studio I have. I have a MacOs High Sierra Version 10.13.6 with an Intel chip.

I downloaded R 4.2.3 . Could you tell me which R Studio is compatible and perhaps provide the link?

Can you do a base plot? E.g. type


and ENTER at the console.

If that works, then can you type this at the console, with ENTER after both lines?

ggplot(mtcars, aes(x = gear, y = mpg)) + geom_point()

does that not show anything on the 'Plots' pane?

They both show up in the Quartz window, but not in the pane.

Why do you have a Quartz window from RStudio?
Did you customize your graphics device?

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.