Plots always saved to PDF but not shown in the "plots" pane

Hi, I'm using RStudio Server v2023.06.1+524, and R 4.2.0 on Debian, and my plots are not showing in the "plots" pane, but being saved to a PDF named "Rplots.pdf".

I tried upgrading RStudio Server,, etc, still when dev.list() is NULL, dev.cur() shows null device 1, any new plots I make go to a pdf.

Other user accounts using the same RStudio Server have no problem showing in the "plots" pane, which is baffling me...

I'm hoping someone here can help me solve this frustrating issue. Thanks very much in advance!

Hi @Shannon
Do you have any code in an .Rdata file that is triggering this behaviour every time you start RStudio/R? Also, check your other startup configuration files.

Thank you for your response! I saved to an .RData file and clear the global environment, and now the plots can show in the "plots" area.. Even after I reloaded the saved .RData file back and restarted the R session, it still works.

So although I'm still not sure what in the global environment could have caused the problem, the problem is solved!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.