Version:1.0 StartHTML:0000000107 EndHTML:0000001384 StartFragment:0000000127 EndFragment:0000001366
Does Quality Profile function in DADA2
Error in plotQualityProfile(fnFs[1:2]) : could not find function "plotQualityProfile" > plotQualityProfile(fnFs[1:2]) Error in plotQualityProfile(fnFs[1:2]) : could not find function "plotQualityProfile"

Have you loaded the library that defines plotQualityProfile?

If you would like a better answer, please tell us more than just the error message.

Hi, I am running into a problem when trying to visualize the quality profile of the forward and reverse reads. I followed all the instructions in the DADA2 tutorial, but I have not be able to fix this problem. I have loaded ggplot2.

I have Rstudio 3.6.2 and library ggplot2. I wonder if the combination defines plot Quality Profile

do you have library(DADA2) in your code ?

I attempted library "ggplot2" and warning message came that the package was built under R 363. I have R 362. Do i need to download the 363 version?

Are you saying this because your original issue has been solved ?
I thought you were struggling to find the function plotQualityProfile, I assumed this was because you omitted library("DADA2")

please clarify

My original issue was solved after I downloaded 363 version.
I now got smoothly through the DADA2 tutorial until the species assignment. I downloaded the silva_nr_v132_train_set.fa and placed it to the directory, into the folder with my fastq sequences.
Yet below the error message. What could be wrong?
taxa <- assignTaxonomy(seqtab.nochim,

  • "C: /Users/salme/Desktop/SYNCdata/NGS2019/2423 endo/UNZIP/silva_nr_v132_train_set.fa",
  • multithread=TRUE)
    Error: Input/Output
    no input files found
    dirPath: C: /Users/salme/Desktop/SYNCdata/NGS2019/2423 endo/UNZIP/silva_nr_v132_train_set.fa
    pattern: character(0)

The error is saying it can't find your files at the given path.

Maybe take a look, you can use dir() to see what files are in some path.

dir(path="C:/Users/salme/Desktop/SYNCdata/NGS2019/2423 endo/UNZIP")

an invalid path will give you character(0) result

maybe its a typo but looks like you had an odd gap between C: and /Users

Yes, I did. Please find below. Still smth wrong....what possibly?

dir(path = "C:/Users/salme/Desktop/SYNCdata/NGS 2019/2423 endo/UNZIP"
+ )
 [1] "~$st tutorial.docx"                                "~WRL1522.tmp"                                      "24 jul"                                           
 [4] "2423UNZIP"                                         "30 juuli"                                          "30 juuli history"                                 
 [7] "filtered"                                          "last tutorial.docx"                                "SILVA_LICENSE"                                    
[10] "silva_nr_v128_train_set.fa.gz"                     "silva_species_assignment_v128.fa.gz"               "TA-2423-Rhizo2Ser205-1-ENDO_S58_L001_R1_001.fastq"
[13] "TA-2423-Rhizo2Ser205-1-ENDO_S58_L001_R2_001.fastq" "TA-2423-Rhizo2Ser205-2-ENDO_S59_L001_R1_001.fastq" "TA-2423-Rhizo2Ser205-2-ENDO_S59_L001_R2_001.fastq"
[16] "TA-2423-Rhizo2Ser205-3-ENDO_S60_L001_R1_001.fastq" "TA-2423-Rhizo2Ser205-3-ENDO_S60_L001_R2_001.fastq" "TA-2423-Rhizo2Ser211-1-ENDO_S64_L001_R1_001.fastq"
[19] "TA-2423-Rhizo2Ser211-1-ENDO_S64_L001_R2_001.fastq" "TA-2423-Rhizo2Ser211-2-ENDO_S65_L001_R1_001.fastq" "TA-2423-Rhizo2Ser211-2-ENDO_S65_L001_R2_001.fastq"
[22] "TA-2423-Rhizo2Ser211-3-ENDO_S66_L001_R1_001.fastq" "TA-2423-Rhizo2Ser211-3-ENDO_S66_L001_R2_001.fastq" "TA-2423-Rhizo2Ser229-1-ENDO_S70_L001_R1_001.fastq"
[25] "TA-2423-Rhizo2Ser229-1-ENDO_S70_L001_R2_001.fastq" "TA-2423-Rhizo2Ser229-2-ENDO_S71_L001_R1_001.fastq" "TA-2423-Rhizo2Ser229-2-ENDO_S71_L001_R2_001.fastq"
[28] "TA-2423-Rhizo2Ser229-3-ENDO_R_filt.fastq.gz"       "TA-2423-Rhizo2Ser229-3-ENDO_S72_L001_R1_001.fastq" "TA-2423-Rhizo2Ser229-3-ENDO_S72_L001_R2_001.fastq"
[31] "TA-2423-Rhizo2Ser42-1-ENDO_S55_L001_R1_001.fastq"  "TA-2423-Rhizo2Ser42-1-ENDO_S55_L001_R2_001.fastq"  "TA-2423-Rhizo2Ser42-2-ENDO_S56_L001_R1_001.fastq" 
[34] "TA-2423-Rhizo2Ser42-2-ENDO_S56_L001_R2_001.fastq"  "TA-2423-Rhizo2Ser42-3-ENDO_S57_L001_R1_001.fastq"  "TA-2423-Rhizo2Ser42-3-ENDO_S57_L001_R2_001.fastq" 
[37] "TA-2423-Rhizo2Ser72-1-ENDO_S61_L001_R1_001.fastq"  "TA-2423-Rhizo2Ser72-1-ENDO_S61_L001_R2_001.fastq"  "TA-2423-Rhizo2Ser72-2-ENDO_S62_L001_R1_001.fastq" 
[40] "TA-2423-Rhizo2Ser72-2-ENDO_S62_L001_R2_001.fastq"  "TA-2423-Rhizo2Ser72-3-ENDO_S63_L001_R1_001.fastq"  "TA-2423-Rhizo2Ser72-3-ENDO_S63_L001_R2_001.fastq" 
[43] "TA-2423-Rhizo2Ser97-1-ENDO_S67_L001_R1_001.fastq"  "TA-2423-Rhizo2Ser97-1-ENDO_S67_L001_R2_001.fastq"  "TA-2423-Rhizo2Ser97-2-ENDO_S68_L001_R1_001.fastq" 
[46] "TA-2423-Rhizo2Ser97-2-ENDO_S68_L001_R2_001.fastq"  "TA-2423-Rhizo2Ser97-3-ENDO_S69_L001_R1_001.fastq"  "TA-2423-Rhizo2Ser97-3-ENDO_S69_L001_R2_001.fastq" 
[49] "tax"                                              
> taxa <- assignTaxonomy(seqtab.nochim,
+ "C:/Users/salme/Desktop/SYNCdata/NGS 2019/2423 endo/UNZIP", multithread=TRUE)
Error in .Call2("fasta_index", filexp_list, nrec, skip, seek.first.rec,  : 
  reading FASTA file C:/Users/salme/Desktop/SYNCdata/NGS 2019/2423 endo/UNZIP/~$st tutorial.docx: ">" expected at beginning of line 1

if you are taking all files, and not just those with fastq in the suffix , then you will try and fail to treat a ~$st tutorial.docx as though it were a fastq.

Than you but i dont get it. Should i take all files....

(files_to_do <- dir(path = "C:/Users/salme/Desktop/SYNCdata/NGS 2019/2423 endo/UNZIP/*.fastq"))
 taxa <- assignTaxonomy(seqtab.nochim, files_to_do, multithread=TRUE)

Thank you! I got the message below. How to proceed?

files_to_do <- dir(path = "C:/Users/salme/Desktop/SYNCdata/NGS 2019/2423 endo/UNZIP/*.fastq")

taxa <- assignTaxonomy(seqtab.nochim, files_to_do, multithread=TRUE)
Error in tax[[1]] : subscript out of bounds

I've never used this function. Is it in principle able to process multiple files or not?
If not you would iterate using purrr map functions

I am afraid I don't understand. what does it mean tax[[1]] : subscript out of bounds?

Here is an explanation.
Run it and think about what it shows

var <- c("a","b")


Version:1.0 StartHTML:0000000107 EndHTML:0000003986 StartFragment:0000000127 EndFragment:0000003968
I started anew and seems multithreading not possible....what does it mean?
frrom the console :
out <- filterAndTrim(fnFs, filtFs, fnRs, filtRs, truncLen=c(200,200), + maxN=0, maxEE=c(2,2), truncQ=2, rm.phix=TRUE, + compress=TRUE, multithread=TRUE) # On Windows set multithread=FALSE Multithreading has been DISABLED, as forking is not supported on .Platform$OS.type 'windows' > head(out) reads.out TA-2423-Rhizo2Ser205-1-ENDO_S58_L001_R1_001.fastq 80846 79511 TA-2423-Rhizo2Ser205-2-ENDO_S59_L001_R1_001.fastq 88318 86841 TA-2423-Rhizo2Ser205-3-ENDO_S60_L001_R1_001.fastq 74490 72962 TA-2423-Rhizo2Ser211-1-ENDO_S64_L001_R1_001.fastq 89280 87813 TA-2423-Rhizo2Ser211-2-ENDO_S65_L001_R1_001.fastq 74096 72708 TA-2423-Rhizo2Ser211-3-ENDO_S66_L001_R1_001.fastq 84392 82972 >

so set multithread to false, its not supported in windows. you are limited to one cpu core

seems still problem...

out <- filterAndTrim(fnFs, filtFs, fnRs, filtRs, truncLen=c(200,200),
+                      maxN=0, maxEE=c(2,2), truncQ=2, rm.phix=TRUE,
+ compress=TRUE, multithread=FALSE)
Error: UserArgumentMismatch
  file 'C:\Users\salme\Desktop\SYNCdata\NGS 2019\2423 endo\UNZIP\filtered\TA-2423-Rhizo2Ser205-1-ENDO_F_filt.fastq.gz' exists, but mode is not 'a'
> head(out)