pkgInfo not available

I'm on the newest R version, and tried to backdown to another version but still get an error when trying to run various charts saying pkgInfo not found. When I try to install it, it says it is not available for this version of R.

Is there a fix for this?

pkgInfo is not an R package, it refers to something else, can you post the complete error message you get? Or even better a REPRoducible EXample (reprex) illustrating your issue?

This is the error:

package �assertthat� has no 'package.rds' in Meta/Error in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]) :
object 'pkgInfo' not found

The problematic package is assertthat. Is your package library in a cloud synced folder? If you don't know run this command and post the output


It is in a OneDrive location and I tried running the RStudio as admin and changed it to a local one and still had issues. What do I need to do?

Move your library to a non synced folder and change the default path, maybe you will need to reinstall some packages too, like assertthat.

You can change the default library folder by setting your R_LIBS_SITE environmental variable on a .Reviron or .Rprofile file

# In a .Renviron file you can set it by adding this line
R_LIBS_SITE="C:\\Program Files\\R\\R-4.0.3\\library"

For a more detailed explanation, you can read this blog post

1 Like

Thank you, I was able to get it working!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.