Persistent problem installing tidyverse and stringr

On earlier reported problem, I was just oppurtuned to try it out now. After installing the package tidyverse from the tools icon, and tried loading it by using the command library (tidyverse), this was what I saw:
Error : package or namespace load failed for 'tidyverse' in namesspaceexport(ns, exports) :
undefined exports: str_sub<-, boundary, college, fixed, invert_match, regex, str_c, str_interp, str_length and so on......

I really don't know what's going on, please help. Thanks

Or are there some other IDEs I could use, what do you think it's the problem.

Did your installation succeed?

install.packages("tidyverse", dependencies = TRUE)

Once it's installed you should be able to load/attach the library (note, no space between library and the parentheses:


What versions of R and RStudio are you using? (see FAQ below for disambiguation)

I don't think the problem is with the IDE. But, if you try with the Vanilla R GUI and it works, then I could be wrong (though, after that, you should certainly be able to load the library in RStudio, since it's running R)

Note that if you see the following in the console output after running install.packages(tidyverse):

Warning in install.packages :
* installation of package ‘tidyverse’ had non-zero exit status

then the installation did NOT succeed (yes, this warning could be clearer!)

1 Like

My version of R is 3.5.1

The installation was successful

I just tried all your instructions now, no positive result. The same problem

Rstudio is version 1.1.456, R is 3.5.1

It’s hard to diagnose something like this without more information. Can you please try:

  1. Restart R (in RStudio, command/ctrl-shift-F10)
  2. Run the following again:
install.packages("tidyverse", dependencies = TRUE)
  1. Paste all of the console output here
Restarting R session...

> install.packages("tidyverse", dependencies = TRUE)
Installing package into ‘C:/Users/HP/Documents/R/win-library/3.5’
(as ‘lib’ is unspecified)
also installing the dependency ‘feather’
Package which is only available in source form, and may need compilation of C/C++/Fortran:
  These will not be installed
trying URL ''
Content type 'application/zip' length 92541 bytes (90 KB)
downloaded 90 KB

package ‘tidyverse’ successfully unpacked and MD5 sums checked
package ‘tidyverse’ successfully unpacked and MD5 sums checked

The downloaded binary packages are in

> library(tidyverse)
Error: package or namespace load failed for ‘tidyverse’ in namespaceExport(ns, exports):
 undefined exports: str_sub<-, boundary, coll, fixed, invert_match, regex, str_c, str_conv, str_count, str_detect, str_dup, str_extract, str_extract_all, str_flatten, str_glue, str_glue_data, str_interp, str_length, str_locate, str_locate_all, str_match, str_match_all, str_order, str_pad, str_remove, str_remove_all, str_replace, str_replace_all, str_replace_na, str_sort, str_split, str_split_fixed, str_squish, str_sub, str_subset, str_to_lower, str_to_title, str_to_upper, str_trim, str_trunc, str_view, str_view_all, str_which, str_wrap, word


Hmm…I think all of these exports are from stringr. Super strange that that would happen, but try installing stringr alone, and then loading the tidyverse library.

install.packages("stringr", dependencies = TRUE)

Alright, would do that. Thanks alot.
But what is the basic source of all these problems? Also, are there no ways I can put a permanent stop to all these problems? Seeing that I'm still very new to R programming language, managing stuffs like these at this early stage will be very tedious couple with the fact that I'm currently running a course (computational thinking and problem solving) on edX (which I started late) and keeping up with the course since the inception of these probles has always been a nightmare and I'm seriously running out of time. Any candid advice, please. Hoping to hear from you soon, thanks.

I've never seen this specific problem before. Hopefully it's something weird with your stringr installation, and this will fix it, and you'll be done with installation issues.

Another option would be to use for your course! It's free, and I just installed the tidyverse in a fresh build, zero problems.

Here's a fresh cloud project with the tidyverse installed: Posit Cloud

Alright.... Thanks alot, I'll try out the two options and give you a feed back.

And please I would like to ask, I was just thinking if I'll eventually be making use of the web Rstudio ( Would that not accelerate my data usage to a very high level seeing that I'll be operating on the internet and will require data charges for every bit of time spent making use of the platform? And also won't there be serious complications just in case I have bad internet connection? Thanks.

Yes, a web service like RStudio Cloud might get expensive in the long run if you’re on a metered internet connection. However, using it as a stopgap now doesn’t lock you into anything — once you’ve solved your Desktop installation problems, you can always download the scripts, etc. that you made in Cloud and keep going in RStudio Desktop.

1 Like

Alright..... Thanks

I sincerely appreciate your efforts. I'll try installing the stringr package and try loading my tidyverse with it as you've instructed. I'm really hoping my Rstudio will be restored in no time. Thanks

Hi, I don't know if anyone ever got to the bottom of this problem, but I just encountered the same error when trying to load the tidyverse after I updated to R 3.5.1.

For me, updating feather and updating stringi solved the problem. Both packages had to be compiled from source, feather 0.3.1 and stringi 1.2.4. stringi took about 10-15 minutes to compile on my laptop.

Hope that's useful.


Forgot that this might be useful information too. I'm running Windows 10

R version 3.5.1 (2018-07-02)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows >= 8 x64 (build 9200)

Matrix products: default

[1] LC_COLLATE=English_United States.1252  LC_CTYPE=English_United States.1252   
[3] LC_MONETARY=English_United States.1252 LC_NUMERIC=C                          
[5] LC_TIME=English_United States.1252    

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
[1] compiler_3.5.1 tools_3.5.1    yaml_2.2.0