Parallel package no longer available in Cran?

I updated to R 4.0.0 last week and now it looks like I can no longer use the 'parallel' package. I tried to reinstall the package but all that I get is this -

package ‘parallel’ is not available (for R version 4.0.0)

Was the package removed as a part of the update? If so, is there any other package I can use for parallel computing?

parallel has been part of R core for some time now, so there should be no need to reinstall it.

1 Like

But why can I no longer find it on cran? Also running an install.packages('parallel') gives the error that it isn't available for R version 4.0.0 :lying_face:

CRAN doesn't contain the core packages, so you cannot install them from there.

Just enter library(parallel)


It's because the parallel package is part of R itself, and is installed at the same time as your R runtime.

You don't need to install parallel, simply start using it:


I tried running library(parallel) but got this -

‘parallel’ is not a valid installed package

can you run sessionInfo() and paste the results here ?

I just reinstalled R and now I have the parallel package. Looks like the package was somehow lost during the update. Thanks everyone!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.