packages for Rstudio 4.0.2

I have installed the new version of Rstudio, but I realized there are a lot of packages not available for the new version, what I am supposed to do?

R 4.0.2 is the current version of the R language. RStudio is a graphical user interface to R. Packages available to R are available to RStudio.

The message

> install.packages("foo")
Installing package into ‘/usr/local/lib/R/site-library’
(as ‘lib’ is unspecified)
Warning message:
package ‘foo’ is not available (for R version 4.0.0) 

can be due to several things:

    • No quotes around package name
    • Incorrectly selected repository name
    • Connectivity, proxy, firewall settings
    • System write permissions

Hi, Richard

thank you for your reply, I supposed to write R not Rstudio. anyway, I have tried to install an old version of R but still have the same issue for other packages, in which I found the packages that was not available for the newest version, but I can not install the packages that are only available for the newest version, I am new in R programming, please guide me through this problem, now I am using the R version 4.0.0, I wanted to install colorRamp2 package, this is what the warning showed: package ‘colorRamp2’ is not available (for R version 4.0.0)

Are you using

install.packages("the_name") # quotation marks

What operating system are you on?

Do you connect to the internet through a managed service, such as a university account?

Do you have system write permissions on your computer?

You are getting that message because colorRamp2 is not an R package, very likely it's a function from the circlize package.

many thanks to technocrat and andresrcs for your help, that is really helpful, the issue is solved

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.