Packages are not updating

RStudio version 2023.03.0+386, MacBook Pro, MacOS Ventura 13.3.1 (a).

I run Update Packages from the IDE, get a list of packages to update, select them all, they all download. But then when I do Update Packages again, the list of packages needing updates is still there. Usually this list is cleared of packages that have successfully updated. This seems to have happened as of yesterday; it had been working normally prior to that. No error messages; it just does not update the packages.

This started with R 3.4 for macOS. It happens when there is a source version newer than the binary. It just reinstalls the binary without giving you a choice or a warning. Once a newer binary is on CRAN, everything is fine. I either wait or run install.packages() with type = "source".

This happens on both RStudio and R, and both m1 and intel computers.


Thanks for your reply. So the change is that RStudio no longer gives you the choice of installing from source, not that the binaries are not installing. So I will just wait for newer binaries to become available.

I just tried installing a couple of the packages by forcing a source install, and it worked. Interesting.

Thanks again!

I don't think this is the fault of RStudio, with its updater just sending install.packages() to the Console. The same thing also happens with the R GUI.

I am surprised that there have not been more posts about this. Are we just the unlucky ones having this issue?


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.