Package won't install into Rstudio - non-zero exit status

Hi I've been trying to install MALDIrppa into my R studio, I couldn't find it in the cram repository so I downloaded the .gz file and tried to install that:

install_version("MALDIrppa", version = "1.0.2", repos = "")

packageurl <- ""
install.packages(packageurl, repos=NULL, type="source")

Neither method seems to work and I keep getting the error seen below:

Version:1.0 StartHTML:0000000107 EndHTML:0000001672 StartFragment:0000000127 EndFragment:0000001654

install.packages("~/R/R_MALDI/MALDIrppa_1.0.1.tar.gz", repos = NULL, type = "source") Installing package into ‘C:/Users/ruthw/Documents/R/win-library/3.5’ (as ‘lib’ is unspecified) ERROR: dependencies 'signal', 'robustbase', 'wmtsa' are not available for package 'MALDIrppa' * removing 'C:/Users/ruthw/Documents/R/win-library/3.5/MALDIrppa' In R CMD INSTALL Warning in install.packages : installation of package ‘C:/Users/ruthw/Documents/R/R_MALDI/MALDIrppa_1.0.1.tar.gz’ had non-zero exit status

Any help or guidance on what to do would be highly appreciated.

Try installing from GitHub


Thanks that has worked perfectly - what is the difference? I'm trying to understand what I'm doing so that I can improve but I'm quiet new to it all

You were trying to install and old version from the CRAN archive, whereas with github you are installing the latest development version which might include some fixes recently added.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.