Package 'metacont' not available for R version 4.0.2

Hi everyone

I've been doing my meta-analysis while working with R version 3.6.2, but needed to upgrade it & install Rtools for a specific package (dmetar). I've succesfully installed R version 4.0.2. and Rtools version 40, and have been able to install dmetar, meta & metafor, but when I try to install the metacont package I get the following error:

Installing package into ‘C:/Users/hilde/Documents/R/win-library/4.0’
(as ‘lib’ is unspecified)
Warning message:
package ‘metacont’ is not available (for R version 4.0.2)

I'm relatively new to R, does anybody know how I could get the metacont package to work?

Thank you so much in advance!



From a quick internet search, it seems there is no metacont package, but a metacont() function from the meta package.

Hi Andres,

Thank you for your very fast reply! I guess you are right, I think a got a bit thrown off:
I was looking for a solution for the following error, and thought it would be in the metacont function, but I see now that it is not.
The problem is this:

When I try to run the forest() function, I get the following error:
Error in forest.default(MIMAMotorImptot, text.addline1 = "Motor Impairment. Analysis 1", :
Must specify either 'vi', 'sei', or ('', 'ci.ub') pairs.

The code that I'm trying to run is the following:
forest(MIMAMotorImptot, text.addline1= "Motor Impairment. Analysis 1", xlab="SMD >0 favours intervention", comb.fixed = TRUE, test.overall.fixed = TRUE, col.fixed="steel blue", col.diamond.fixed = "steel blue", comb.random = TRUE, test.overall.random = TRUE, fontsize = 10, = 1, digits.mean = 1, col.random = "red", col.diamond.random = "red")

It ran perfectly every time under R version 3.6.1., do you have any ideas what it could be? I've been stuck for the entire afternoon :(( Thank you so much for your help!

Well, that is a different question, I recommend you to ask it on a new topic providing a proper minimal REPRoducible EXample (reprex). A reprex makes it much easier for others to understand your issue and figure out how to help.

If you've never heard of a reprex before, you might want to start by reading this FAQ:

Hi Andres,

Thank you for your fast reply (again), it makes perfect sense that I have to give more information for this to be fixed. I read your FAQ, I will upload a reprex tomorrow morning, thanks again!
Buenas noches :slight_smile:

I don't know why it worked, but this was the solution:
I deleted the R version 4.0.2. and re-installed version 3.6.1., in which I loaded the Rtools40.
The dmetar package worked this time and I didn't get any errors anymore

Just to clarify, Rtools40 won't work with R < 4.0.0 so most likely it is not related to this.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.