Package installation freezed at lazy loading

Hi ,
Does anyone meet the same issue? I installed the package at another macpro and worked; however, on new MacBook 2021, package installation freezed at lazy loading for 12 hours, the following is my code and code feedback:

install.packages("~/Downloads/OutlierDetection_0.1.0.tar.gz", repos = NULL, type = "source")

  • installing source package ‘OutlierDetection’ ...
    ** package ‘OutlierDetection’ successfully unpacked and MD5 sums checked
    ** using staged installation
    ** R
    ** byte-compile and prepare package for lazy loading

Not sure what the problem is, but you can try with:

remotes::install_version("OutlierDetection", version = "0.1.0")

If you're lucky that could work better.

Hi Alexis,

Thank you so much!
It worked pretty well, the package was installed successfully.

But do you know any way that I could command the package as the way like library()? Since I guess librabry doesn't work for remotely installed package; if I do so, then library() is running forever, just like what happened on lazy loading.

Then it didn't work: remotes::install_version() is basically equivalent to install.packages(), just that it lets you choose the version. What is surprising then is that it didn't fail during installation.

Also, I tried running that on my computer (Windows 10, R4.1.1), and it worked, I can load and use that package.

One thing, if the installation was successful but the library(OutlierDetection) call fails, you can try not loading the package, and directly using OutlierDetection::OutlierDetection() or the relevant function.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.