Package Installation failure....

I don't know if anyone else had similiar issue but I'm trying to install packages on R Studio Mac OS and I get the message that rpanel is missing. When I try to install rpanel I get this message Warning message:

installing the source package ‘rpanel’

trying URL ''
Content type 'application/x-gzip' length 716333 bytes (699 KB)

downloaded 699 KB

  • installing source package ‘rpanel’ ...
    ** package ‘rpanel’ successfully unpacked and MD5 sums checked
    ** using staged installation
    ** R
    ** data
    *** moving datasets to lazyload DB
    ** demo
    ** inst
    ** byte-compile and prepare package for lazy loading
    Error in structure(.External(.C_dotTcl, ...), class = "tclObj") :
    [tcl] can't find package BWidget.

Error: unable to load R code in package ‘rpanel’
Execution halted
ERROR: lazy loading failed for package ‘rpanel’

  • removing ‘/Library/Frameworks/R.framework/Versions/3.6/Resources/library/rpanel’
    Warning in install.packages :
    installation of package ‘rpanel’ had non-zero exit status

The downloaded source packages are in

I installed BWidget but it still shows sth like the above. If anyone have any solution please share and thanks!

Hi, and welcome!

Please see the FAQ: What's a reproducible example (`reprex`) and how do I do one? Using a reprex, complete with representative data will attract quicker and more answers.

Of course this type of question doesn't need one.

I just tried and got the same result with this message

** byte-compile and prepare package for lazy loading
Error in structure(.External(.C_dotTcl, ...), class = "tclObj") : 
  [tcl] can't find package BWidget.

The question that this poses is which package for what program is being referred to. Andrew Cassidy may have an answer from) back in 2014.

It involves downloading and installing the BWidget program, and then the install with either work or come back with the next obstacle!

Related info:

On macOS, packages sometimes fail to install, often with a non-zero exit status message. This is due to Apple's idiosyncratic compiler. The same packages will install on most Linux systems without trouble. Saint Simon Urbanek of the R Core Development Team takes on the brain damage required to recode the source to get around macOS's peculiar worldview for those in CRAN, but he can't bestow the same mercy on those still in development.

Some packages will successfully install through compilation from source, but many won't.

When installing if you are offered the option to install from source, it makes sense to try it once. But, if at first it doesn't succeed, in all likelihood it never will. It's usually only 7-10 days until a macOS binary is available

Try again

Sadly, this package requieres tcl/tk and nothing depending on X11 will work in RStudio Cloud, including tcl/tk and similar packages.

1 Like

Good to know. It appears that this is a local installation, tho'

removing ‘/Library/Frameworks/R.framework/Versions/3.6/Resources/library/rpanel’

so I hope the install of the external program works for the OP

@Lucy1 can you clarify?

Well, I just understand that r-release for rpanel is not available on Mac OS. I think I should give up installation.

Thank you so much for explanation! I have installed the BWidge but don't know where to put it? In the R.framework file? Or somewhere?

1 Like

So you are not using RStudio Cloud, it would be better if you take this out of your post since it could be confusing for people trying to help you, RStudio Cloud runs on Linux servers, not MacOS

1 Like

I haven't used the BWidge installer. It doesn't need to, and probably shouldn't, go in R.framework, because it is likely to be wiped out when upgrading R versions. Look in recent files to find where it wound up. As long as that is in your $PATH, you should be good

Okay, thank you for telling!

Thank you! I will try!

1 Like

OK, let everyone know when it works and come back with any related questions in this post or start with a new post for other questions.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.