Package build missing separator error

I have a package that used to build on my old machine. I just tried to build it and I am getting an error. Apparently this is related to tabs vs spaces but I can't figure out how to fix it.

This is the Build log:

==> Rcmd.exe INSTALL --preclean --clean model_package

* installing to library 'C:/Users/woodwards/Documents/R/win-library/3.6'
* installing *source* package 'BASGRA' ...
** using staged installation
** libs

*** arch - i386
Makevars:17: *** missing separator.  Stop.
Makevars:17: *** missing separator.  Stop.
Makevars:17: *** missing separator.  Stop.
ERROR: compilation failed for package 'BASGRA'
* removing 'C:/Users/woodwards/Documents/R/win-library/3.6/BASGRA'

Exited with status 1.

Here is Makevars. It is crashing on the last line.

PKG_FCFLAGS += -x f95-cpp-input -fdefault-real-8 -Dweathergen

C_OBJS = basgrac.o
FT_OBJS = parameters_site.o parameters_plant.o environment.o resources.o soil.o plant.o set_params.o basgraf.o

all: $(SHLIB) clean


resources.o set_params.o soil.o environment.o: parameters_site.o parameters_plant.o
plant.o: environment.o
basgraf.o: plant.o resources.o set_params.o soil.o environment.o
basgramodule.mod: basgraf.o
basgrac.o: basgramodule.mod

@rm -rf *.mod *.o

For some reason RStudio is putting a @ at the start of the last line. It should be a tab I think. If I put a tab or space or nothing there, it gets converted to a @ which causes the error. Help!


Maybe it's because my project is on One Drive, which is on a Unix machine, but RStudio is expecting a Windows machine.

SOLVED. In the last line of Makevars the @ is supposed to be a TAB. It seems to have got there due to switching between Unix and Windows.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.