"<p> R encountered a fatal error. </p>The session was terminated."

I was working with RStudio normally one day before. I turned RStudio off and turn it on again today. The error message "

R encountered a fatal error.

The session was terminated." pumps out and I can no longer open RStudio. I uninstalled and reinstalled. I still cannot open it. I've seen some debugging tutorials on Windows. I am using macOS Sierra version 10.12.6. Anyone have some ideas/tutorials on how I should solve it? Thanks!

I tried every method listed https://support.rstudio.com/hc/en-us/articles/200488508-RStudio-Desktop-Will-Not-Start
The RStudio still not working. Can someone help me? Thanks a lot!

Have you tried updating your R version? If you've updated RStudio recently, it may be that you're experiencing compatibility issues between the specific versions of R and RStudio you're running.

Hi Jason,
I uninstalled and installed both R and R Studio. It was still not working.

Finally I figured it out. I have to use the command line to remove the hidden .Rapp.history and .RData. I was using command line to find the hidden folder RStudio-Desktop. Actually those hidden files critical to open RStudio are under my home directory not the RStudio-Desktop.
Thank you very much for your Answer.

The problem is now solved by removing hidden .RData and .Rapp.history in the command line.
rm -f .RData
rm -f .Rapp.history
I am unfamiliar with using command. I was trying to find it in the hidden RStudio-Desktop folder and it was not inside this folder.

1 Like