Optimal "autosave" option settings while syncing using dropbox? Windows10


Thank you for the updated RStudio IDE with the enhancements to improve the experience while using a sync'ed folder!

I often have to use RStudio on multiple machines and so I am using Dropbox (all on Windows) to keep my project folders sync'ed.

I have been trying to figure out the optimal settings to use with my Dropbox. However, I'm still having issues where I am still getting never-ending "Error saving" pop-ups which completely block my ability to actually do anything in the IDE.

I have configured the Auto-save options as:

Automatically save when editor loses focus: unchecked
When editor is idle: Backup unsaved changes
Idle period: 2000ms

I'm confused because i will get these popup warnings even if my idle times never get anywhere near that 2 second threshold.

Only way I've found to fix the problem is to disable the Dropbox sync, and then re-enable it later, which kind of defeats the purpose.

Does anyone have any suggestions?


Does the error tell you which file it's having trouble saving?

Does the problem still occur if you set "When editor is idle" to "Do nothing"? (wondering if this is related to auto-save at all if it happens regardless of the idle interval)

I don't remember a specific file, but next time it starts happening again, I'll try to make a note of whether or not it does.

I'll also try switching to "Do Nothing" at that time as well.


Hi Jonathan,

So it has happened again, although this doesn't seem to be the same.

Atleast for this instance, you may be right.

After I "save" (or export) a large file (this one is just shy of 500MB), I'm unable to "save" the .Rmd file. It gives the error in this screenshot and won't let me save my changes until the dropbox upload is finished. Changing the "When editor is idle" to "Do Nothing" had no effect in this case.

Any idea why exporting this file would prevent me from saving the changes to my .Rmd?RStudio error

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.