Onebox links not working


Until recently, pasting links in in their own lines used to create a preview of the site. But it seems to stop happening.

First example:

Second example:

In both the cases, I can see the preview as earlier. Same happens while I try now in this question as well.

But these seem to be gone after posting. Is it some setting issue in my browser, or happening with others as well? I really like these previews.



I noticed this too, and after bit of research I found out that this forum is likely built on the Discourse software.

These previews are only generated if the webpages in question have the correct oEmbed /OpenGraph tags. If not, the link is not displayed in a box. You can see it in the preview though, but it displays an error message like I had in one of my recent posts:

Notice how the link to this post itself does show the box, because of course Discourse has implemented the correct tagging in its own system.

From what I read, there's nothing the forum folk can do about this, it's all at the creators of the external websites to have proper tags listed. Plus given privacy issues it seems that in some cases this is becoming a harder thing to implement (the details elude me :))

Hope this helps,

Thank you for the reply.

I don't follow why it stopped working all of a sudden, as same links worked earlier. I'm sure I shared links for R docs, and especially R4DS a lot in the past. It worked then. So, it seems that they must have correct tags. Even old FAQ had these things, which seem broken now:

Stack Overflow and Github links seem to work fine even now. Not sure what else. I checked few other forums, for example Manjaro one, and onebox seems to work there fine.

Do you mean that something changed recently in this forum particularly? Or, am I missing something obvious?

(Sorry, but I'm extremely unfamiliar with HTML and related stuff, so tags are not for me :sob: . Please bear with me on this.)


I'm as unfamiliar with all of this as you are don't worry :stuck_out_tongue_winking_eye:

It's just that I found this interesting and had noticed it too so I did some online research to see if I could learn more and that's what I shared. The only reason I can come up with that it might have worked in the past, but not anymore, is that some new privacy policies on certain websites have switched this off, hence it disappearing now, but I have no good source to prove that...

Let's hope someone more knowledgeable joins in and provides a more satisfying explanation


1 Like

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.