Not install package funcy

Hi everybody,
this morning I tried to install the package "funcy" in my R software. I use the versione 3.6 and 4.0.3 and in both the version was impossible to install this package because the package is not available.
Somebody have a idea to resolve this. I need absolutely this package to make the Functional Cluster Analysis.
Have a nice weekend

The package is no longer on CRAN, but you can try to install it from github.

1 Like

Thanks. I try but I saw this message:
"> remotes::install_github("cran/funcy")
Downloading GitHub repo cran/funcy@HEAD
Error in utils::download.file(url, path, method = method, quiet = quiet, :
cannot open URL ''"

If I try this script

The RStudio start to load the package and after appear this message "Error: Failed to install 'unknown package' from URL:
(converted from warning) installation of package ‘nloptr’ had non-zero exit status"

If you click this link/ try it in a browser, what happens?

Appear this message:
"> install.packages("C:/Users/giorgia 7/Downloads/cran-funcy-1.0.1-0-g3711a9e.tar.gz", repos = NULL, type = "source")
Warning in untar2(tarfile, files, list, exdir, restore_times) :
skipping pax global extended headers
ERROR: dependencies 'flexclust', 'fda', 'wavethresh', 'kernlab', 'car', 'fields', 'calibrate', 'sm' are not available for package 'funcy'

  • removing 'C:/Program Files/R/R-3.6.0/library/funcy'
    Warning in install.packages :
    installation of package ‘C:/Users/GIORGI~1/DOWNLO~1/cran-funcy-1.0.1-0-g3711a9e.tar.gz’ had non-zero exit status"

This is a list of packages hat funcy wants to have been installed before funcy.

I try to install this before the package funcy. Thanks

This seems like a connectivity issue to me, is your internet connection behind a firewall or proxy server? That is usually the case when you are at school or work.

I tested the github installation on RStudio Cloud and it worked without any issues so the github repository is OK.

After I installed all these packages, after 10 min of downloading I saw this message:
Error: Failed to install 'unknown package' from URL:
(converted from warning) installation of package ‘C:/Users/GIORGI~1/AppData/Local/Temp/RtmpsbozQi/remotes220605a42f/funcy’ had non-zero exit status

Finally work only with your file zip.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.