Not able to push files to my GitHub rep

Hi everyone.

I'm trying to push my files to my GitHub, but I'm getting the following error:

error: cannot run rpostback-askpass: No such file or directory
fatal: could not read Username for '': Device not configured


  1. I'm using MAC

  2. I'm linking my project to GitHub with HTTP protocole

  3. I ran git config --global and user.mail in the terminal

  4. I tried to use the solution of running git push -u origin main and when I type in my credentials it gives me the error "authentication failed". I never changed my password to GitHub, I checked it today to enter the website, it works.

  5. I tried using ssh protocol instead but it seems to be giving me even more errors even though I created my ssh key and added it successfully to my GitHub.
    Specifically when I click on create new project and add the ssh link Rstudio says:

> Cloning into 'data-science-hw'...
> ssh_askpass: exec(rpostback-askpass): No such file or directory
> Host key verification failed.
> fatal: Could not read from remote repository.
> Please make sure you have the correct access rights
> and the repository exists.

I went through all the possible suggestions I could find on the internet but none of them worked.
I would be very happy if anybody has any idea what else I could try..

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.