Not able to load tidyverse . - `object 'vI' not found`

Although I have tried a lot of solution including installing tidyverse with dependencies and reinstalling the other packages but still on the command library('tidyverse')
it is giving an error :: package or namespace load failed for ‘tidyverse’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
object 'vI' not found
i have the latest versions


Could you try

install.packages("tidyverse", dependencies=TRUE)

failing that,


and failing that, system info may be useful;

Some system information

#### System Information:
- RStudio Edition: (Desktop or Server)
- RStudio Version: 
- OS Version: 
- R Version: 

#### Also:
<!-- Depending on your issue, the following may be useful /-->
<!-- If a section isn't relevant or you can't collect it just delete that section below /-->
- RStudio diagnostics report: <!--see /-->
- Your `sessionInfo()`:
- RStudio crash report: <!-- /-->
- RStudio application log files: <!-- /-->
1 Like

Thanks for the reply but Ive already tried that. And I dont know why this problem is only with tidyverse rest all packages are working just fine
session info()
R version 3.5.0 (2018-04-23)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows >= 8 x64 (build 9200)

Matrix products: default

[1] LC_COLLATE=English_India.1252 LC_CTYPE=English_India.1252 LC_MONETARY=English_India.1252
[4] LC_NUMERIC=C LC_TIME=English_India.1252

attached base packages:
[1] stats graphics grDevices utils datasets methods base

loaded via a namespace (and not attached):
[1] Rcpp_0.12.17 bindr_0.1.1 magrittr_1.5 tidyselect_0.2.4 mnormt_1.5-5
[6] lattice_0.20-35 R6_2.2.2 rlang_0.2.1 plyr_1.8.4 dplyr_0.7.5
[11] tools_3.5.0 parallel_3.5.0 grid_3.5.0 nlme_3.1-137 psych_1.8.4
[16] yaml_2.1.19 assertthat_0.2.0 tibble_1.4.2 bindrcpp_0.2.2 purrr_0.2.5
[21] tidyr_0.8.1 glue_1.2.0 compiler_3.5.0 pillar_1.2.3 foreign_0.8-70
[26] pkgconfig_2.0.1

Have you tried removing the package? You can delete it in R with:


but sometimes it's also helpful to go in and manually make sure the folders and contents are gone from your system.

After you've done that, try installing again.

hey mara,
I've also tried that but still its the same error

package ‘tidyverse’ successfully unpacked and MD5 sums checked

The downloaded binary packages are in
installing the source package ‘feather’

trying URL ''
Content type 'application/x-gzip' length 59616 bytes (58 KB)
downloaded 58 KB

  • installing source package 'feather' ...
    ** package 'feather' successfully unpacked and MD5 sums checked

    WARNING: this package has a configure script
    It probably needs manual configuration

** libs

*** arch - i386
C:/PROGRA~1/R/R-35~1.0/etc/i386/Makeconf:230: warning: overriding commands for target .m.o' C:/PROGRA~1/R/R-35~1.0/etc/i386/Makeconf:223: warning: ignoring old commands for target.m.o'
make: *** No rule to make target `$(CXX11STD)''. Stop.
ERROR: compilation failed for package 'feather'

  • removing 'C:/Users/user/Documents/R/win-library/3.5/feather'
  • restoring previous 'C:/Users/user/Documents/R/win-library/3.5/feather'
    Warning in install.packages :
    installation of package ‘feather’ had non-zero exit status

The downloaded source packages are in

Error: package or namespace load failed for ‘tidyverse’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
 object 'vI' not found

What's the output of your .libPaths()?

"C:/Users/user/Documents/R/win-library/3.5" "C:/Program Files/R/R-3.5.0/library"

ive use env variables

Are the packages in whatever path you have set in your .Rprofile or wherever you're storing your environmental variables?

I just installed tidyverse in a fresh 3.5 installation, and it worked fine.

Another thing to try is running install.packages() without installing dependencies. It looks like there's something weird going on with feather for you, and that's just a Suggests.

I have reinstalled everything
and the error changed to unable to load tidyverse as package 'stringi' could not be found
I' ve installed stringi but the same issue
I think if u could just assist me in giving how to specify a lib in R that would be best if there is other way than env variables as Ive already done that

You can add your desired path to your .Rprofile if you want to avoid environmental variables:

Your .Rprofile will have to be in your default working directory:

I don't work in Windows, but if you're not the admin on your machine, there's another way of setting your environmental variables suggested in the comments to this answer:

is there any way to install obects like here the nasty one object 'vl'

That's part of base R's package loading, I believe. It's not a constant you can just set. I could be wrong, though.
Below see all the instances of that code on GH:<-+i[[1L]]%2C+c(lib.loc%2C+.libPaths())%2C+versionCheck+%3D+vI[[j]])&type=Code

Yeah, you can see it here in the CRAN mirror:

Thanks For your help I will have to load everything explicitly that would work . You could close this issue now
thanks a lot

2 posts were split to a new topic: 'Object vI not found' upon package install