not able to install r package DESEq2

Error Information:

Description of issue - gcc -std=gnu99 -I"/usr/share/R/include" -DNDEBUG -fpic -g -O2 -fdebug-prefix-map=/build/r-base-V28x5H/r-base-3.6.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g -c attrutil.c -o attrutil.o
gcc: error: unrecognized command line option ‘-fstack-protector-strong’
gcc: error: unrecognized command line option ‘-Wdate-time’

Installation path not writeable, unable to update packages: backports, caTools, cli, digest,
ellipsis, fansi, farver, ggplot2, glue, gtools, lifecycle, pillar, plyr, Rcpp, remotes,
reshape2, rlang, scales, stringi, tibble, vctrs, withr, nlme, spatial

Steps taken so far - i tried to install these packages with the new version of r (4.0) but then also it is showing the same error
if (!requireNamespace("BiocManager", quietly = TRUE))

System Information:

  • RStudio Edition: Desktop
  • RStudio Version: 1.3.959
  • OS Version: ubuntu 18
  • R Version: 3.6

From Troubleshooting Guide: Using RStudio

Please post the command you are using to install the package and the whole message you are getting (BTW this is not related to the IDE so I have changed category).

1 Like

hey, i have done that can you please provide me the solution.

Where have you done it? I don't see the command you are using and I only can see a portion of the message.

1 Like

see in the steps taken part

I can't replicate your issue, I also use Ubuntu 18 and I can install it without problems, but here are a some things to try

  • Make sure you have r-base-dev installed
sudo apt-get install r-base-dev
  • Update this packages before trying to install DESEq2
  • Try to install as superuser