no font could be found for family ...


I recently re-downloaded R on my macbook with the macOS Mojave version 10.14.15
While trying to do simple exercises such as creating a histogram or a scatterplot, I get the following result (along with my figure):

There were 50 or more warnings (use warnings() to see the first 50)

When I enter the given command, I get:

no font could be found for family "Arial"

I have seen that other users have had the issue but even when going to "All Fonts" in my Finder, the issue is not resolved.

I have also tried changing the font, but it results in the same warning messages with a different font name instead of Arial.

I have tried this with two different versions of R: Version 1.2.1578 and Version 1.2.5001.

If anyone has an idea has to how to go about solving this, I'd really appreciate it!

Thank you very much!

Could you provide a brief reproducible example? Basically, short bit of code that gets the error you're seeing. Does something like this get the same error?


Restore standard fonts

  1. Open the Font Book app
  2. File > Restore Standard Fonts...
  3. Restart computer

if that doesn't remedy the situation...

Check your user fonts directory

Does /Library/Fonts contain the fonts you're looking for but ~/Library/Fonts missing them? Check from the terminal command line:

ls /Library/Fonts
ls ~/Library/Fonts

If so, you could try copying the contents from the system fonts into your user fonts directory. Also from a terminal command line:

cp /Library/Fonts/* ~/Library/Fonts/

Yes the bit of code you provided generates the same error, and so I don't get any types of writing on my histogram (for ex: title and axis titles)

I get the same error for:


the only thing that changes is the number of warnings, but they are all of the same type

Restoring the standard fonts doesn't help.

As for the for the fonts directory, copying the contents gives me the following line

usage: cp [-R [-H | -L | -P]] [-fi | -n] [-apvXc] source_file target_file
       cp [-R [-H | -L | -P]] [-fi | -n] [-apvXc] source_file ... target_directory

does that seem correct? is there something to do after this? after getting this I tried making a histogram again but still got the warnings.

Getting a usage message usually indicates the command wasn't entered correctly. Perhaps they syntax I gave was incorrect. In either event, the files were not copied over.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.