New version of Rstudio can't recognize chinese characters

I updated my rstudio yesterday from Version 1.4.1106. I run list.files() to generate a list of files which contain chinese characters in the file name. The results are all weird characters and it has never been an issue before. I tried multiple ways to fix this, but it turns out the only way to fix this is to reverse back to the old version of rstudio. Can someone please help look into this?

What version of R are you using? There's a fix for this in the upcoming release of RStudio, which should be out within a week or so. You can get it here:

I think I have the same problem. I change from RStudio-pro-1.4.1717-3 to RStudio-2021.09.2-382, and could not install any package, because something was wrong with PATH, HOME with non recognized French accent. Hence I could not install Rtools or any other package. I desinstall the latest version and reinstalled the old one. Do you think that by installing these 2022.02.0 version it should work?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.