New RStudio Crashes when Restarting R Session on Network Drive

I've been using the new RStudio (Version 1.1.383) on a Mac (Sierra Version 10.12.6) for the last 2 days and it crashes when I try to restart the R session. Here is the sequence of events:

  • Mount a network drive
  • Open RStudio
  • Open RStudio Project from the network drive
  • Do work
  • Press shift-command-f10 to restart the R session
  • Crash...

Here is the error message:

ERROR system error 45 (Operation not supported) [lock-file=/tmp/.Rproj.user/B6148186/sources/s-37259BA1/lock_file]; OCCURRED AT: virtual rstudio::core::Error rstudio::core::AdvisoryFileLock::acquire(const rstudio::core::FilePath &) /Users/rstudio/rstudio/src/cpp/core/file_lock/AdvisoryFileLock.cpp:137

It has something to do with being on a network drive because when I do the same thing on my local drive I have no problem with restarting R. I've been using the same workflow for a long time and never had this issue with prior RStudio versions.

Here are my specs:

R version 3.4.2 (2017-09-28)
Platform: x86_64-apple-darwin15.6.0 (64-bit)
Running under: macOS Sierra 10.12.6

Matrix products: default
BLAS: /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
LAPACK: /Library/Frameworks/R.framework/Versions/3.4/Resources/lib/libRlapack.dylib

[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

Any ideas?

What kind of network drive is this? RStudio attempts to use hard links (created by the equivalent of calling ln from a shell) when creating lock files; is it possible the network drive you're trying to use doesn't support hardlinks?

It's SMB. I tried to hard link in the shell to the lock file and I get ln: ./lock_file: Cross-device link. So this must be the issue.

This issue did not exist in the prior RStudio version. Will this revert at some point?

Looking at this again, you shouldn't be making use of our hardlink-based locking scheme (that is an RStudio Server only feature). The locking scheme that you're using hasn't changed since RStudio v1.0, so I'm actually not sure what would have changed to cause this issue.

Does RStudio v1.0 still work fine with this mounted folder? My only guess is that file locking is simply not enabled on this drive.

Yes RStudio v1.0 works fine with this mounted drive.

The only other thing I see that's a little bit suspicious:

Note the path being used here:


RStudio is attempting to write a lockfile for internal state to a project (?) living directly within the /tmp directory (?). Is this truly a project that you've opened in the /tmp directory, or could something else being going on here?

No the project doesn't live in /tmp. I edited the error message because the original path was lengthy. I've tested the behavior with other project directories (ones that I have full access to) and I get the same error. I don't get the error when using RStudio v1.0

Got it; thanks. We're now tracking this issue at; we'll see if we can try reproducing this issue.

Can you also let us know what

nfsstat -m

tells you about the network drive being mounted (if anything)?

nfstat -m returns nothing. Thank you for following up and tracking the issue!