Multi-User Issue

I get that RStudio server is for multi user environments but is there an issue with running RStudio(free, not server) on a Windows server and people just login and use it? The Windows server allows for multiple logins(different user accounts) at a time.

For an example, I am not a true user of the software, mainly an IT person trying to understand, we run this:

prior1 <- prior(normal(0,10), class = b) + prior(cauchy(0,2), class = sd)
fit1 <- brm(count ~ zAge + zBase * Trt + (1|patient),
data = epilepsy, family = poisson(), prior = prior1)

And get an error:

Compiling Stan program...
make cmd is
make -f "C:/PROGRA~1/R/R-43~1.0/etc/x64/Makeconf" -f "C:/PROGRA~1/R/R-43~1.0/share/make/" CXX='(CXX14) (CXX14STD)' CXXFLAGS='(CXX14FLAGS)' CXXPICFLAGS='(CXX14PICFLAGS)' SHLIB_LDFLAGS='(SHLIB_CXX14LDFLAGS)' SHLIB_LD='(SHLIB_CXX14LD)' SHLIB="file3a187e2f52ff.dll" WIN=64 TCLBIN= OBJECTS="file3a187e2f52ff.o"

make would use
Warning message:
In system(paste(cmd, "-n")) : 'make' not found
Error in compileCode(f, code, language = language, verbose = verbose) :
Error in system(paste(MAKE, p1(paste("-f", shQuote(makefiles))), "compilers"), : 'make' not foundCalls: -> .shlib_internal -> systemExecution halted
Error in sink(type = "output") : invalid connection

I was able to run these commands and get it fixed for one person but when I ran it on the other persons profile, it seemed to break the first person:

remove.packages(c("StanHeaders", "rstan"))

Rebooted R

install.packages("rstan", repos = c([Repository for distributing (some) stan-dev R packages | r-packages, getOption("repos")))

Pic because the forum is formatting the text.

Rebooted R

It seems like the one that is installed by default is not compatible with the current version of R which is why this fixes it but like i said, the issue is when I fix it for one person, the next is broken. I guess Rstan is not compatible with rtools42 and thats why using the preview(?) version is working but not sure how to fix everyone.

RStan Compatibility

I would love to say i know what I am doing, I am trying to learn but its slow, this seems much more like programming than an OS issue which I am use to finding solutions for our people.

How much support do you actually get if you pay for RStudio? I am just not sure about how to support this as a free program without any support. Interestingly enough, the same error occurred on their cloud instance, someone tried it, I assume the same fix would work but i think their cloud is linux based so its not a Windows issue.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.