Missing knit directory menu with current versions of R and Rstudio

First time posting, so please let me know if I've not included sufficient details.

I'm trying to get to the root of why my ability to select a knit directory for markdown documents disappears when I download the newest versions of R and RStudio.

I work in consulting and we often have a constant rotation of reports in progress that can leave me behind on updates as I avoid shifting mid-analysis. I took advantage of a rare gap in reports yesterday to update both R and RStudio. When I began a new set of analyses, however, I found that I no longer had an option to change my knit directory, either from the drop down menu next to the knit button nor from the global options box, making it impossible to read in data files in our project oriented workflow. The issue disappeared when I uninstalled R 4.2.1 and reverted to my previous version of R 4.0.3 (while still using the latest RStudio 2022.02.3+492). From there, I worked my way backward from the newest release of R until the knit directory menu reappeared with R 4.0.5. Given I had to go back 7 versions and the first version I run into this issue with is from May 2021, it seems unlikely this is a common issue. I'd also like to find a solution that lets me use the newest version if possible before I run into other issues from being out of sync.

Can you share what you see exactly ?

This is with current preview version of RStudio

RStudio 2022.07.0+548 "Spotted Wakerobin" Release (34ea3031089fa4e38738a9256d6fa6d70629c822, 2022-07-06) for Windows
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) QtWebEngine/5.12.8 Chrome/69.0.3497.128 Safari/537.36


I see the menu.


platform       x86_64-w64-mingw32               
arch           x86_64                           
os             mingw32                          
crt            ucrt                             
system         x86_64, mingw32                  
major          4                                
minor          2.1                              
year           2022                             
month          06                               
day            23                               
svn rev        82513                            
language       R                                
version.string R version 4.2.1 (2022-06-23 ucrt)
nickname       Funny-Looking Kid     

With 4.0.5, mine looks the same as yours. With any later version, this option is just gone. I'm also realizing the knit parameters line in the drop down is gone.
image (1)

Oh interesting. That is odd. Are all required packages install ?

Newer minor or major version of R means newer user library and so new installation to make. Are rmarkdown and friends already installed ? I believe IDE won't error if package are missing, and it will ask to install at first rendering, but before I suppose some feature could be disabled until installed and reloaded

Just a wild guess

OoOo, that did the trick! I normally just responded to requests to install as I've encountered them and I've not run into a situation when updating in the past where this was an issue. But installing those before interacting with any markdowns has revived the knit directory menu!

Interestingly, in this process I also found that R 4.2 versions were all leaving behind files that didn't clear out during uninstall.

Thanks so much for your help!

1 Like

Glad it works !

If your question's been answered (even by you!), would you mind choosing a solution? It helps other people see which questions still need help, or find solutions if they have similar problems. Here’s how to do it:

Done! Thank you for the helpful guidance as I figure out the standard procedure!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.