Microsoft Visual C++ Runtime Error


I am from Novartis. Rstuido users are facing an error Microsoft Visual C++ Runtime Library in RStudio 1.0.153.

The screenshot of the error is following.

Moreover, users are able to use the package when they are run it as an administrator, otherwise they cannot use it.

Please let us know any resolution for this issue. Many users are not able to use Rstudio because of this.

Piyush Kukreti

What version of Windows is being used?

Hi Gary,

Thanks for replying. So users are who are impacted by this issue are using windows 10.
Most of them recently had a transition to Windows 10.

Do let me know any update from your side. Will wait for your response.

Thanks and regards,
Piyush Kukreti

We've seen a number of issues lately with recent updates to Windows-10. I'm not sure if this is related to that, though.

Have you tried a more recent version of RStudio, such as 1.1.453?

Hi Gary,

We have checked users machines and they all have got some recent updates on their windows 10 machine. So even I believe that updates to windows-10 might be an issue.

Coming to the second point we are in the packaging phase for Rstudio 1.1.442 right now. But it will take some time to get approvals, test it and then make it global and we are looking for an immediate workaround or hotfix as more and more users are coming up with the same issue.

Moreover, I wanted to add one more thing that users are able to use the software package if they run it as an administrator.

Please do let me know if you get some resolution or workaround for this issue.

Piyush Kukreti

Hi Gary,

As you know we were using RStudio 1.0.153 before, so in pursuit of resolution to the ongoing issue we have upgraded the version to Rstudio 1.1.442. But the issue still persists.

More and more users are coming up with the issue as they switch to windows 10.
Do let us know if you find any leads regarding this problem.

Piyush Kukreti

I am experiencing exactly the same error, also on Windows 10. Rstudio has run on my machine for ages without complaint. It happened after a reboot.

It is a problem of Windows 10, and Visual C++ rtl, rather than RStudio.
I seem to have found a solution on youtube:
From an elevated command window, issue
bcdedit /set IncreaseUserVA 2800
After a reboot, everything worked again :slight_smile:

unfortunately, it did not help on the long run. The same error came up when trying to change to another project. Now RStudio is dead again.

Yeah that's what the problem is. I tried using "bcdedit /set IncreaseUserVA 2800" command with some of the impacted users. But it could not help us resolve the issue.

I believe, Rstudio is having some internal issue which needs to be addressed soon and there has to be a concrete solution for this issue otherwise, the desktop version of Rstudio will slowly become Obsolete.

Oh hopefully this is going to be fixed! I use RStudio in my first year course in statistics. The students will panic if this happens on their machines. And what if it happens during the exam?
Maybe it is an attack by some SAS supporters that want to avoid industry going R :wink: RStudio has made R so much more attractive. Cool that you use it @ Novartis!

Sorry to hear updating to 1.1.442 didn't help. I have opened an issue on this:

Could you also try the latest release, 1.1.453, just to see if that makes any difference. I don't expect it to, actually, but be good to confirm that.

Also, if possible, please try the latest daily build of RStudio 1.2. Daily builds are intended for testing purposes, and are not recommended for general use. There have been numerous fixes and tool updates in 1.2, however, and there's a good chance this has fixed the problem. Knowing that, we can look at what it would take to update RStudio 1.1 to address the issue.

Thank you!

1 Like

Thanks Gary for taking this issue to the next level.

Regarding switching to a newer version; we just switched from RStudio 1.0.153 to Rstudio 1.1.442 so it will again take a whole lot of time to package a new version and deploy into the production. So switching again is not a possible way out for us in near future.

I Hope we get some resolution soon.

Hi Piyush,

We're sorry to hear that you're having troubles.

I am one of the main contacts for the Novartis account at RStudio and would be interested in discussing this further with you and ensuring we see it to resolution. If you'd like to email me at any point so we can do so, please send a note to

Thank you!

Lauren Chadwick

Thank you for your patience. This is not an issue that most RStudio users are encountering on Windows-10, and I cannot reproduce the problem. I can install RStudio 1.0.153, 1.1.453, and 1.2.826 onto a clean Windows-10 machine and run them with no problems.

So I will need your help in troubleshooting to figure out what it is about your environment that triggers the issue.

First, what specific version of Windows-10 do you have? I am testing on Pro, 64-bit 1803, build 17134.165.

What version of R do you use?

How are you installing RStudio? Do you use the RStudio installer, or are you bundling up the files yourselves as part of an image to apply to machines?

If you are creating your own installation image, then I need to know if installing onto a test machine configured in your standard configuration, using the RStudio installer, also has the problem. Need you to conduct that test, using both the currently released 1.1 build (1.1.453), and if possible, the latest daily build (1.2.826). Goal is to find it these work when installed via the standard RStudio installer. That hopefully gives us some clues about what to investigate next.


For what it's worth, I face the same issue, but can resolve it by deinstalling (and reinstalling) git after every system restart. There is a related thread on github:

Happened to me after installing R-tools for RStan

Very interesting! Thanks for pointing that out, I've added a reference to that issue from the one I opened earlier. Not sure if they're the same underlying cause yet, but certainly very similar symptoms.

Is it possible for you to give a daily build of RStudio 1.2 a try just to see if anything changes? Usual caveats about 1.2 being very much a work in progress, not ready for production use, and so on.

Hi Gary,
I've this problem and I've noticed that if I load RStudio at the very beginning of the Windows startup, the program starts normally. Otherwise if I wait few seconds after the complete WIndoes start up, RStudio raises the error.

Other behaviour, it raises the error also when I'm trying to save a plot as an image when I'm clicking on Export -> Save as Image

I don't know if these insights can be helpful.

Thank you

This is interesting - same with my computer: I can start RStudio right after the start of Windows, but not two seconds later it refuses. Also further copies are not possible.

Faulting application name: rstudio.exe, version: 1.1.456.0, time stamp: 0x5b4d1c33
Faulting module name: rstudio.exe, version: 1.1.456.0, time stamp: 0x5b4d1c33
Exception code: 0x40000015
Fault offset: 0x000c23f0
Faulting process id: 0x23a8
Faulting application start time: 0x01d42e1b0c9a0923
Faulting application path: C:\Program Files\RStudio\bin\rstudio.exe
Faulting module path: C:\Program Files\RStudio\bin\rstudio.exe

Would you be willing to generate a Windows minidump for us? The process for enabling this on Windows involves setting some environment variables, as per Note that this does require administrator privileges.

If you want to enable / disable crash dumps more easily, you can try importing the registry keys I've set up here:

The dump files generated can be somewhat large (~50MB) so it'd be best if you could share a downloadable link with e.g. DropBox, Google Drive, or another similar provider.