Memory limits ignored by "start local job"?

We have RStudio Server Pro 1.2 and set it up to limit users to 50GB of RAM across all of their sessions combined. With the "start local job" feature, it seems each job running has this 50GB limit, so the settings aren't respected. I can't find documentation about how to augment the profiles.conf, etc. with settings to avoid this. Are there any?


If you're using max-memory-mb, that applies to every process:

The max-memory-mb setting controls the maximum amount of addressable memory for R sessions (by default memory is unlimited). [...] Note that this value sets the amount of virtual memory that can be used by a process.

In other words, if you're setting that to 50GB, each session (and job) will get 50GB.

RSP uses ulimits to police resource usage, and these are per process by design. If you want to enforce a limit that spans a collection of processes (such as all R sessions and jobs run by a user), you'll need an external tool such as cgroups:


Yeah we were sort of hoping to avoid setting cgroups up in this case, but it's not a big problem either to do so. We just wanted to be sure we weren't missing anything from the documentation. Thanks for replying quickly!

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.