M4Comp2018 package wont install

I am having trouble installing the M4Comp2018 package in the RStudio Cloud.

(This package was made for the 2018 M4 copetition on time series - https://www.mcompetitions.unic.ac.cy/the-dataset/ - by Pablo Montero-Manso, Carla Netto, and Thiyanga Talagala.)

It should be installed using devtools::install_github("carlanetto/M4comp2018"), but I am getting the following (cloud only):

Installing package into ‘/home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.6’
(as ‘lib’ is unspecified)

  • installing source package ‘M4comp2018’ ...
    ** using staged installation
    ** R
    ** data
    *** moving datasets to lazyload DB
    Error in i.p(...) :
    (converted from warning) installation of package ‘/tmp/Rtmpyj3RjE/file157b3e32fe/M4comp2018_0.1.0.tar.gz’ had non-zero exit status

I tried to download, build and install the package manually, but the same error occurs.
Can anybody help?

Building this package is exceeding the 1 GB memory limit. We are able to build and cache CRAN packages, but not other packages at this time.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.