lwgeom won't build when deploying Shinyapp.io

Hi All,

I'm trying to deploy a new app onto shinyapp.io that uses sf to import a shp file which works locally. However, when I try to publish, I encounter the following error on building lwgeom:

* installing to library ‘/opt/R/3.6.1/lib/R/library’
* installing *source* package ‘lwgeom’ ...
** package ‘lwgeom’ successfully unpacked and MD5 sums checked
** using staged installation
configure: CC: gcc
configure: CXX: g++ -std=gnu++11
configure: pkg-config proj exists, will use it
checking proj_api.h usability... no
checking proj_api.h presence... no
checking for proj_api.h... no
configure: error: proj_api.h not found in standard or given locations.
ERROR: configuration failed for package ‘lwgeom’
* removing ‘/opt/R/3.6.1/lib/R/library/lwgeom’

Does anyone know any fixes on this? I saw a previous post about turning off Package Cache but this doesn't work.

Thank You!

It looks like lwgeom has had an issue recently. If you install from GitHub to pick up this fix, does it work?

Hi @josh, thank you that worked! Appreciate it.


Hi, I'm having the same issue with no luck. I've tried using the most recent version from Git. Able to install locally, but not on ShinyApps.io.

@Ftallis could you show the command you used to install from GitHub?
What is the output of rsconnect::appDependencies()?