Lost Git tab after several days working

I imported a new project from my bitbucket.org account and It worked properly. After several days working, doing commits, push, pull, now I can not see the Git tab.
If I create a new project it works well.

Anything to get Git tab again?


Very interesting. Are you able to share the URL for the project?

I am not 100% sure how this works on RStudio Cloud, but I know that in the IDE you need to be in a git repo to show the git tab. You probably have the project open, so this shouldn't really be an issue, but what does pwd or ls -lha or git status give you in the terminal? It's important to be sure that nothing happened to your git repo.

Hi Cole, I don't know how can I do pwd or ls -lhm commands because with Rstudio Cloud I don't have access to the shell.

This is the URL project: https://rstudio.cloud/project/14237



You can access the shell by using the Terminal tab in RStudio. See the screenshot below.

However, I suspect the issue here is that you need to open the project file to re-enable Git support. You can do this by navigating to project (.Rproj) file in the "Files pane, and opening the project file for your GitHub project.


1 Like

Andy it worked!
Now I have again my Git tab visible.

Thank you very much
Great job resolving my issue.

Thanks Rstudio team.
Best regards
Alfonso Carabantes

A bit detail, when I went to commit I had an error telling:

git commit -F /tmp/Rtmp1RvJ1f/git-commit-message-3191c8aecad.txt

*** Please tell me who you are.


git config --global user.email "you@example.com"
git config --global user.name "Your Name"

to set your account's default identity.
Omit --global to set the identity only in this repository.

I executed the commands with my user information and it worked great!

Alfonso Carabantes