Loading files into Cloud from local folder.

Very new to using RStudio Cloud. Am running in Chrome on Wondows 10 laptop.
Have followed the sequence Files, Upload, Choose file, Import. The chosen file is in the local Documents folder. Cloud tries to import but returns error message Permission Denied.

I think this may be to do with local file permissions but I don't know or what to set the access to.

Using the RStudio app on the laptop the command sequence works fine and I can open the Excel file.

Problem is that my students are restricted to Chromebooks and so will only be working with Cloud. (As a test I managed to upload a file from my Google Drive on my own Chromebook so I may have a work around that my students could use).

Perhaps I should just stick to one OS and upload to Google Drive as necessary.

Any ideas to limit this switching between devices and systems?


Hello there,

What is your target directory for the upload? Is it /cloud/project? Are you able to upload other files?
Also, could you share a screen shot of the Permission Denied message?

Thanks for responding.
I was collecting some screen shots of the sequence of commands when I found that the selected .xlsx file did load. I then tried it with other files; all worked fine.

I have no idea what was going on the other day. Just makes me feel incompetant but at least more confident that my students should be able to start their journey in R.

Sorry to have troubled you.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.