load tidyverse returns error message

After serious problem with tensorflow/keras/conda, I just gave and uninstalled anaconda and R/RStudio.

After all being installed again I installed the most important packages I need in a daily basis. Tested it running a few scripts and then. No issues... even with the keras. Everything back to normal.

Though, I don't know what caused this... library(tidyverse) returns this error:

Error: package or namespace load failed for ‘tidyverse’ in inDL(x, as.logical(local), as.logical(now), ...):
 unable to load shared object 'C:/Users/pedro.david/Documents/R/win-library/4.0/xml2/libs/x64/xml2.dll':
  LoadLibrary failure:  %1 is not a valid Win32 application.

Tried many solutions to similar problems... but still not able to fix this.
It seems that I can live with this... as I can load each of the tidyverse core packages separately. But it is kind of annoying... And we all know that this loose ends probably will smack my face in the future.

My session info :

R version 4.0.3 (2020-10-10)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 18362)

Matrix products: default

[1] LC_COLLATE=English_United States.1252  LC_CTYPE=English_United States.1252   
[3] LC_MONETARY=English_United States.1252 LC_NUMERIC=C                          
[5] LC_TIME=English_United States.1252    

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
[1] compiler_4.0.3 tools_4.0.3  


Do you get any error message if you reinstall the xml2 package? (Restart your R session before trying)

1 Like

Hello @andresrcs,
yes it solved.

Thanks a lot

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.