Library not writeable

Trying to install a package from CRAN (matrixcalc) into an RStudio Cloud project. As soon as I click install in the IDE, a window "Create Package Library" is displayed asking if I want to create a personal library with a Yes / No choice. If I choose Yes, the window repeats. If I choose No I get a message that the library is not writeable.

Hello, We are looking into this but are having trouble reproducing it. What happens if you run this in the console:


Also, what is the url for your project?


Also, if this continues to fail, can you provide a screen shot of the error, and a list of already installed packages (sessionInfo()) thanks!


Just ran

from the console and it worked. Have no idea why it worked today and not yesterday.
Thank you.

Great to hear. Thanks for letting us know!

I wonder if your libPaths got changed somehow. If you are still having the issue when using the Install button outside of installing from the console, can you let us know what the following returns?


[1] "/home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.6"
[2] "/opt/R/3.6.0/lib/R/library"

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.