libraries not running in rstudio

I have updated rstudio because everything stopped working, after I ran a file clean up manager, I reinstalled libraries from scratch,it warned me 00LOCK file was preventing libraries running, I have deleted this and started to run, they still will not load, here is the message, I ran install again now I have this warning, after trying to load the library.
Loading required package: xts
Loading required package: zoo
Error: package or namespace load failed for ‘zoo’:
package ‘zoo’ was installed by an R version with different internals; it needs to be reinstalled for use with this R version
Error: package ‘zoo’ could not be loaded
In addition: Warning message:
package ‘quantmod’ was built under R version 4.0.3
I have the latest version of Rstudio running?

R Studio is an Integrated Development Environment.
R is a computer language that R studio has been designed to support.
You can find and share your environment info by the command

thanks, I have tried updating my R program to the latest version, and uninstalling the corrupted one, I now have a new R script compiler and a new Rstudio , hopefully, they will sync now.

Also, after a major R update, it is a good practice to update your packages with


I have not found a complete fix it seems all but libraries associated with tidyverse will run and Rmarkdown.
First I did not have Rstudio update my rcompiler version automatically so I went into tools, global options, and changed the version from 3.3.6 to 4.0.4(sic? guess of the top of my head), then I found the 32 bit version of Rstudio was running, updated it to 64 bit,then I ran a batch update of about 60 or so libraries that went through ok, except for tidyverse and related libraries, it is the well troubling namespace exports problem which does not seem to have a one size fits all solution, but a case by case basis, I did run check update libraries which seems to run though it stops on R markdown, more researching needed. It is a very vexing issue as I rely on R for trading for retirement income, and it is critical to get it working ASAP, also crucial Rmetrics libraries are giving strange errors I have not tested whether they work, and it says the fractal library is not available for version 4.0.4? I am literally overwhelmed and have spent ten intense hours already trying to solve unexplainable issues.

If I was you I would start over with a clean R + RStudio installation (including the library folder), then if you are still having issues with package installations, address them one by one, posting the specific (and complete) error message you get in a topic here.

do you mean delete erase everything including all on the libraries path?

wipe all traces of R and start from scratch?

Yes, thats what I mean.
While it is perfectly possible to fix your environment, the fact that you have expended more than ten hours trying to do so, tells me that you don't have much experience with this sort of thing so starting from scratch would be much easier for you. Setting up your basic R environment from scratch should take much less than ten hours.

I actually have used a PC since a casio with inbuilt BASIC in 1981, and first used dos in 1987 I have a very very deep computer knowledge particularly of windows and the underlying kernel, however , R like pythons errors are cryptic, not well documented and contradictory, once a real spanner is thrown into the system their problems become really intractable, a quick look through stack overflow and here shows the total lack of consistency in dealing with what seem identical issues, it is not my knowledge that is lacking it shows what fragile ecosystems these things are built on, however I agree, It could take weeks to solve the problems related to each and every library individually. It is the fix of last resort, destroy and rebuild.

Sadly general computer knowledge doesn't directly translate into quirk R management knowledge as you already discovered and there is no shame in starting from scratch, even if you are more than capable of figuring out a solution if you take a practical approach isn't a quicker solution better? I would rather spend more than ten hours looking at my data than trying to fix my package library.

worked like a charm delete all libraries, rstudio, R.IDE, rTools, loaded latest version, reloaded,and loaded a huge install.packages(c(...."ditto"...,"etc"),dependencies =True)
took about an hour, must have been at least 50 libraries, now I am still adding some loose ends, no problems, works just like a real one.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.