Latest Rtools seems to be incompatible with the latest R

(I imagine my question has nothing to do with RStudio)
I have just updated R to 3.5.0 and need to re-install some packages. I have installed the latest version of Rtools (Rtools35.exe), but then get the following message:

WARNING: Rtools is required to build R packages but no version of Rtools compatible with the currently running version of R was found. Note that the following incompatible version(s) of Rtools were found:

  • Rtools 3.4 (installed at C:\RBuildTools\3.4)

What should be done in this case?

1 Like

It looks like there's an updated rtools: RTools: Toolchains for building R and R packages from source on Windows

Try that and see if it helps.

I suggest removing (or renaming the directory) Rtools3.5, reinstalling Rtools3.4, and trying again.

I had to install data.table from gihub because the CRAN binaries don't work with R 3.5.0 yet and the source didn't build with Rtools3.4, 3.5, or 3.3. Installing from github worked with Rtools3.4 but not with Rtools3.5 My inference is that Rtools3.4 is needed for at least some R-3.5.0 packages.

1 Like

by the link, the latest I see is Rtools35.exe - that's what I used. I don't see any other updated version.

I have reinstalled Rtools (now it's just in c:\Rtools\); from R help, I was told that it was the problem of devtools package. When I try to execute something like devtools::install_github("r-lib/devtools"), I get another error message:

Error in system(full, intern = TRUE, ignore.stderr = quiet, ...) :
running command '"C:/PROGRA~1/R/R-35~1.0/bin/x64/R" --no-site-file --no-environ --no-save --no-restore --quiet CMD config CC' had status 254

And when I try to run it manually, by launching c:\Rtools\bin\sh.exe and then executing any command, I get bunch of errors like this:

  1 [main] sh (12212) C:\Rtools\bin\sh.exe: *** fatal error - cygheap base mismatch detected - 0x32E5410/0x3285410.

This problem is probably due to using incompatible versions of the cygwin DLL. Search for cygwin1.dll using the Windows Start->Find/Search facility and delete all but the most recent version. The most recent version should reside in x:\cygwin\bin, where 'x' is the drive on which you have installed the cygwin distribution. Rebooting is also suggested if you are unable to find another cygwin DLL.

and I couldn't find any other cygwin1.dll anywhere...

1 Like

Use this link to update your new version .........V 3.5.0

that's exactly the link I started from

use this line to click zip file wil be download.
R 3.5.0 (codename “Joy in Playing”) was released yesterday. You can get the latest binaries version from here. (or the .tar.gz source code from here).

yes, that's what I used - this doesn't work

rtools is a separate install from R. Have you installed rtools 3.5 or only R 3.5?

sure, I have installed both (R 3.5.0 and Rtools35)

1 Like

I was having this problem too. I reinstalled Rtools 3.5 several times, but finally removing this line from my path
Made devtools::find_rtools() return TRUE instead of an error about compatibility.

1 Like

I used RTools 3.5 and installed data.table CRAN version just fine for R 3.5.0

On getting the same error on a different computer, I ended up uninstalling RTools completely, removing all RTools from my PATH system variable, then reinstalling RTools 3.5 with the default options and selecting to add it to the PATH during install. After that devtools::find_rtools() worked,

1 Like

I was able to fix this by reinstalling RTools35.exe to the c:\\RTools directory (previously was in c:\\RBuildTools) and then MANUALLY removing the old directory from my PATH file.
I've posted as an answer to the related question on stackoverflow

Please read Rtools.txt file in Rtools installation directory. Especially the GCC toolchain section. There is information how to add environmental variable BINPREF. Setting it correctly will fix the issue you are facing.

Had the same problem. All you have to do is to check the option for setting the PATH environment variable at the time of installation. Make sure after installation to open a new R session and check the PATH by doing :-

[1] "c:\\Rtools\\bin;c:\\Rtools\\gcc-4.6.3\\bin;...