Latest RStudio Won't Start

The current version of RStudio, 1.2.1335 won't start on my Windows 10 PC. If I uninstall it, then re-install version 1.2.671, it works until I shut it down. Then I have to uninstall and reinstall to get it to work again.
Here is the first error message (the forum won't let me attach them all). Note that I don't have Jenkins on my machine, so the path must refer to an RStudio developer machine. 2019-08-29_RStudio01
I am running the latest version of Windows 10 and the latest version of R (3.6.1, 64-bit). R starts fine by itself. I also tried renaming my RStudio-Desktop to backup_RStudio-Desktop, and similarly for AppData/RStudio to backup_RStudio (as detailed here: Neither helped. I have also tried uninstalling R, RTools and RStudio, rebooting, and reinstalling them. That didn't help either.

I've run RStudio for years, most recently I ran v. 1.2.671 for about 11 months on the same machine I'm having trouble now. This problem only started when I upgraded to v. 1.2.1335. For a few months, I've been able to uninstall RStudio, then reinstall the old version and run it until I shut it down. Yesterday that stopped working.

Here is the second error that appears once I close the first error.

One possibility: I wonder if you somehow ended up with mismatched components between older and newer editions of RStudio? Does the error go away if you restart the computer, and then reinstall RStudio afterwards?

No. I've tried. Uninstalling RStudio, uninstalling R, rebooting, reinstalling R, reinstalling the latest RStudio. The main IDE comes up with a blank white screen with the menu options at the top, but no menu drops down when I click it.

Interestingly, I ran RStudio version 1.2.671 for about 11 months without a problem. Only when I installed the new version 1.2.1335 did I have problems. Starting yesterday even version 1.2.671 will no longer run.


I've got the same problem since last Windows 10 update. I've tried to press ctrl when starting RStudio, uninstall R & RStudio but nothing fix this problem.

Any other suggestion to fix it ?

Thanks in advance

Are you still seeing this with the latest release of RStudio (v1.2.5001)?

Yes. I uninstalled RStudio, rebooted, followed the steps in:

Then installed the new 1.2.5001.
I have the same issue. I just get a blank screen with the menu at the top, but none of the menus work.
After awhile, I got a popup error saying "Git for Windows has stopped working....". When I close that error, I'm back to the blank screen with the menu at the top.

I haven't gotten mine to work yet. I just tried version 1.2.5001 and that didn't fix it either.

I'm also experiencing the same problem.

I have the same problem on Mac OsX . I am unable to edit the path to git.

It could be worth uninstalling Git for Windows and then trying to launch RStudio again. Perhaps RStudio is trying to interact with Git on startup, in a way that causes things to break?

We've also occasionally seen issues of this form when incompatible command line tools are on the PATH. What is the output of:


from e.g. RGui or an R terminal?

From RGui (64-bit):


I don't have Git for Windows installed.

This sounds similar to the previous RStudio version where it was looking for Jenkins, which I also don't have installed. Does RStudio have a hard coded path that works for the developer but not on other machines?

One idea may be to search the RStudio codebase for the "c:\jenkins\workspaceIDE\windows\src\cpp\r\RExec.cpp" path. Also check your Jenkins build scripts for that path. That may help you track down the problem.

Sorry, the question about Git + make was directed at other users in this thread. I might have misunderstood but I believe they're seeing a different issue from you.

The paths you see logged are the paths used when compiling RStudio, which is on a virtual machine managed by Jenkins (and so has Jenkins in the path). So, it's a bit of a red herring -- we're planning to remove those paths just to avoid this sort of confusion in the future.

Do you have any other files that might influence the R startup process? For example, files at:

  • ~/.Rprofile
  • ~/.Renviron

Or have you customized your R installation in any other way?

The error you're seeing is coming from here:

This is code that tries to set the R repositories on startup, normally based on customized repositories as set in the Tools -> Global Options... -> Management pane. Have you customized anything within that dialog?

I don't have any .Rprofile or .Renviron files in ~.
I can't start RStudio, so I haven't been able to customize it.
I am the one who first logged the Git issue 11 days ago on this thread, so I thought the info on Git was for me too.

I have the same problem. In my case the problem happened after I installed git on my Windows 10 machine. I've tried:

  • Uninstalling and reinstalling Rstudio
  • deleting all of the desktop settings and files in appdata
  • installing old versions of Rstudio

The only solution that I have at the moment is to open Rstudio as Administrator, which is not ideal.

It feels like RStudio is trying to do something with an application that it sees in its path and is unable to and crashes. However, no problems are reported when running the Rstudio diagnostic utility.

I really don't want to blow my OS up and install Linux, or move to another IDE, but very soon I'm going to have to consider doing one of those, as I need a fully functioning setup on this machine.

Any suggestions for some env vars to reset, or something else to try?

Sorry, are you sure you're seeing the same code execution error reported by the OP? It sounds like your symptoms are slightly different. If not, can you confirm that you are seeing that same error?

For what it's worth, for issues of this form, some users have reported a make process churning at 100% in the Task Manager after attempting to launch RStudio. Is that true in your case as well?

In my case it was because I was trying to use git through the Windows Subsystem for Linux. ie RStudio pointed to a git.bat that points to the WSL install of git. Doesn't appear that RStudio can deal with that.

I've installed git-bash and that seems to be working now with RStudio. Not ideal, but it's functional.