knit button not working for document with future_lappy; rmarkdown::render works

I am fitting about 50 models in parallel using future_lapply in an Rmd file. When I run the chunk, everything works fine. In process monitor all cores go to 100%, stay there for a few minutes, then I have my list of fitted models to display and compare.

So once I was sure all my model specifications were correct, I hit the knit button to get output to peruse and work out what these models mean. Went to get coffee and came back to find nothing happening. RStudio window was blank and I had to force exit it.
I tried again with the knit button. The core usage went to 100% for about 30 seconds then dropped back to normal base load. I could see all the spawned Rscript processes, all with 0% cpu usage. And no output.

I force exited and tried rmarkdown::render. Everything worked perfectly.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.