Keyboard Shortcuts on Win 11 RStudio - US International (Layout)


I've recently upgraded to Windows 11 from Windows 10. I usually use and setup the keyboard layout to be " US International" as opposed to the "US" layout because I speak multiple languages and need the symbols etc...

I have never had issues with keyboard shortcuts with RStudio before even when using the International layout. What I've noticed since I've upgraded is that the shortcuts do NOT work if I'm using the International Layout in RStudio.

For example, if I try and use (with the international keyboard layout selected Win+Spacebar to toggle between them) the CTRL+SHIFT+ALT+P to "Run all chunks above" I get this symbol instead: Ö

I've tried a few things but I can't seem to get the desired outcome... I want to have the US International keyboard settings as my default keyboard layout and have the shortcuts for RStudio to work accordingly.

What is the best way to approach this, I'm sure it is a simple configuration issue but I'm unsure on how to go about it to get the desired outcome.

Thanks for the feedback,

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.