Kable() results not displaying inline

I have several R Markdown pages that are suddenly displaying the HTML code rather than the resulting table in my rmd page. They were working fine yesterday. Earlier this week I upgraded R to the latest version. And today my company ran a major Windows upgrade. It showed up after the Windows upgrade.

All of the problematic code chunks look something like this:
arrest_rate %>% select(ArrestRate) %>% kable("html") %>% kable_styling()

The nice-looking tables show up in the viewer in RStudio, but not inline with the code like they used to. Instead there is HTML in the inline spot.

If I knit the page, the HTML page looks perfectly fine.

FYI..I'm a newbie at all this -- less than six months into using R and only about a month into using R Markdown and kable.

Any thoughts on how to fix this?


Somebody else recently had what sounds at first glance like a similar issue:

Does any of the info from that solution help?

No it didn't help. I tried installing htmltools package and it didn't make any difference.


Any other ideas?

I just found this thread, which is spot on with my problem. Issues with R Markdown/Notebook in R 3.5.0 - Not displaying tibble/df nicely inline

1 Like

I just came to this thread to link that one, so I'm glad you already found it! Though I'm sorry it sounds like there's no clear solution yet :disappointed:

I solved the problem- at least temporarily -- by reverting to R 3.4

Ha! Sometimes discretion is definitely the better part of valor (aka you gotta know when to fold 'em) :upside_down_face:

Hello, are there any updates on this issue? I just added a reply to the above thread, but asking here as well since this was the same issue. thank you very much.

The latest RStudio release and preview downloads fix this issue. thank you.

If your question's been answered (even if by you), would you mind choosing a solution? (see FAQ below for how) It makes it a bit easier to visually navigate the site and see which questions still need help.