Issues with R Markdown/Notebook in R 3.5.0 - Not displaying tibble/df nicely inline

Hi all,

I just installed the new R version, 3.5.0. Just like @prosoitos posted here, I had to reinstall each and every package again -- which mostly worked fine (i.e. I did not have the rlang issue mentioned in the linked comment).

However, my RMarkdown files do not display/work as nicely as before within the RStudio IDE (no problems knitting). Additionally (and I am not sure if this is related), there were a number of packages I was not able to reinstall, including the rstudio package.

The main problems I have run into so far is that when I print a data.frame/tibble inline within a chunk, I don't have that nice output like I used to have (with nice scrolling up-and-down or side-to-side) -- it looks just like it would in the console

Has anyone else had this issue?

I know that this isn't a big deal, but I wouldn't be surprised if there are other related issues -- earlier today I had problems using a SQL chunk (i.e starting with {sql}), but that seems to have been magically fixed (not sure how, since I didn't do anything to fix it).

    #> Installing package into 'C:/Users/falan/Documents/R/win-library/3.5'
    #> (as 'lib' is unspecified)
    #> Warning: package 'rstudio' is not available (for R version 3.5.0)

    #> Session info -------------------------------------------------------------
    #>  setting  value                       
    #>  version  R version 3.5.0 (2018-04-23)
    #>  system   x86_64, mingw32             
    #>  ui       RTerm                       
    #>  language (EN)                        
    #>  collate  English_United States.1252  
    #>  tz       America/New_York            
    #>  date     2018-04-24

You could reinstall the last release of rlang without issue? That's good to know as I didn't know if the problem was for everyone or just on my end and I was trying to figure that out to decide whether it was worth posting an issue on rlang. If you could reinstall the whole tidyverse without the devel version, then it was on my side... (no idea why though).

Yes, I was able to reinstall rlang (and have even used it since).. There were a bunch of packages that had similar errors to the rstudio one I mentioned earlier, but (a) those were mostly packages I didn't use much (b) I didn't really have any other major errors. For a few of the packages, I had to run the install.packages() a second time, but it then worked.

OK. Thank you! Very good to know.

1 Like

OK, this just got more confusing.

The nicely formatted table shows up if the data frame is grouped, but not if it does not.

For example, the following code does lead to a standard, non-pretty output:

tibble(x = c("a", "b", "c"), y = 1:3)

while the next code does lead to a pretty output like I saw two days ago under the old R

tibble(x = c("a", "b", "c"), y = 1:3) %>% group_by(x)

However, the following one does not lead to a pretty output

tibble(x = c("a", "b", "c"), y = 1:3) %>% group_by(x) %>% ungroup()

Has anyone else encountered this issue?

I've got the same issue too, also after updating to R 3.5.0.

I'm running the daily RStudio build

1 Like

Thanks for reminding me to be more explicit.

My RStudio version is 1.1.447, the current stable version.

I am having the same issue and also running R 3.5.0 - nothing that I run is displaying inline.

Normally, this could be fixed with Tools -> Global Options -> R Markdown -> Show output inline for all R Markdown documents. However, under Tools -> Global Options the "R Markdown" tab on the left is absent.

I am having the same error (R 3.5.0, RStudio 1.1.447).

Dataframes/tibbles are no longer printing as "paged" tables inline or when previewing notebooks - unless grouped by any variable.
Works as normalwhen knitting RMarkdown HTML documents, but not for R Notebooks.

See example here:

I'm having the same issue as well. I've been plowing through knitr documentation to see if there might be something in the update that assumes different default options. If there is someone more experienced with knitr, I'd be happy to hear from you regarding where to look. Hope this is cleared up soon as I rely on those nice scrolling tables for doing validation and troubleshooting!

You could file an issue on knitr or rmarkdown GitHub pages to let them know about this.

I'm having the same issues with tables built with kable() or DT::dattable, after updating to the latest version of R.

Issue opened on the rmarkdown GitHub page:

1 Like

Thanks for the bug reports, everyone. It looks like this is an IDE issue (we're running afoul of some changes in S3 dispatch behavior in R 3.5.0). I've filed an issue here:

and we'll try to find a fix soon.


Hello, I just upgraded to 3.5 and now tables such as:

kable(update,digits=2,format = 'html') don't render in the console or in the pop up window.
Are there any updated on this? Thank you very much

The problem went away for me when I updated the the RStudio Preview release.

1 Like

This issue is fixed both in the latest RStudio release (v1.1.453) as well as the preview release (v1.2.747-3).