Issues with package installation and CRAN Mirrors - unable to access repository and SSL error

I recently updated to R 3.6.3 for Mac OX (I currently have 10.14). My XQuartz is updated, and I have clang 7.0.0 and gfortran-6.1 installed.

However, when I tried installing the 'ppcor' package I would get this error message

Screen Shot 2020-03-31 at 1.05.16 PM

I tried changing my cran mirror and regardless of the mirror I chose I would get this error message:

Warning: failed to download mirrors file (cannot open URL ''); using local file '/Library/Frameworks/R.framework/Resources/doc/CRAN_mirrors.csv'
Warning message:
In download.file(url, destfile = f, quiet = TRUE) :
URL '': status was 'SSL connect error'

I am new to R and any help would be much appreciated :slight_smile:

Hi, and welcome!

Please see the FAQ: What's a reproducible example (`reprex`) and how do I do one? Using a reprex, complete with representative data will attract quicker and more answers. This question doesn't require one, however. (Still, screenshots usually don't help all that much if they are any smaller than this one.)

I have your setup and just had a successful install. XQuartz and clang/gfortran aren't relevant, since this package didn't require compilation.

I've not seen the SSL error before. Can you connect to https in the browser?

Without an SSL connection, getting the "not available" message is expected.

1 Like

This seems like a connectivity issue, R is not being able to connect to the CRAN repository you have selected, these are some things to try.

  • Choose a different CRAN repository, RStudios repository is a good choice ( or you could choose one that is geographically closer to you.
  • Disable secure download setting.
  • Check if your internet connection has traffic restrictions of some kind, like a firewall, proxy server, etc. This is usually the case when you are at work or school.

Thank you so much for your quick responses! As far as I know, I am able to connect to https on my browser. I had also turned off my firewall before I started up R, but it could be a proxy server issue. This is unusual because I had used R a handful of times before and I never had this come up. I will try RStudios right away.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.