Issues with epiR package; object ‘pandoc_to’ is not exported by 'namespace:knitr'

I first run install.packages("epiR") then library(epiR) and I get the following error message.

Error: package or namespace load failed for ‘epiR’:
object ‘pandoc_to’ is not exported by 'namespace:knitr'

I think this means pandoc_to is no longer contained in the knitr package but I can't seem to find where it is installed. I tried the rmarkdown package but that didn't work. I get the same error message.
Anyone know how to get rid of this error?

R version 4.3.1 (2023-06-16 ucrt)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 19044)

Matrix products: default

[1] LC_COLLATE=English_United States.utf8 LC_CTYPE=English_United States.utf8
[3] LC_MONETARY=English_United States.utf8 LC_NUMERIC=C
[5] LC_TIME=English_United States.utf8

time zone: America/New_York
tzcode source: internal

attached base packages:
[1] stats graphics grDevices utils datasets methods base

loaded via a namespace (and not attached):
[1] utf8_1.1.4 R6_2.4.1 tidyselect_1.2.0 magrittr_2.0.3 glue_1.6.2
[6] tibble_3.2.1 pkgconfig_2.0.3 dplyr_1.1.2 generics_0.1.3 lifecycle_1.0.3
[11] cli_3.6.1 fansi_0.4.1 vctrs_0.6.3 compiler_4.3.1 rstudioapi_0.15.0
[16] tools_4.3.1 pillar_1.9.0 rlang_1.1.1

Check your version of knitr . I have knitr_1.43 and neither get the message nor have any error when using knitr::pandoc_to() directly. (macOS)

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.